AMD-VI IOMMU and Xen hang

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

AMD-VI IOMMU and Xen hang

Piotr Król
Hello Xen users,
I'm working on enabling IOMMU for PC Engines apu2 (GX-412TC). I was able
to clean up patches posted to coreboot long time ago [1].

Unfortunately from time to time I'm facing hangs during Xen boot:

(XEN) CPU1: No irq handler for vector e7 (IRQ -2147483648)
(XEN) CPU2: No irq handler for vector e7 (IRQ -2147483648)
(

Full correct boot log [2].

I was not able so far to narrow down procedure to reproduce the issue
reliably. My setup is as follow:

- Xen 4.8.3 boot over PXE and rootfs over NFS
- Debian stable with Linux 4.14.y (tried couple versions)

I also can't see any pattern in occurrence of this issue, sometimes it
happen that I see 100 consecutive correct boots without issue. Sometimes
can't boot Xen since getting hang each time.

I tried to compile Xen myself, but instructions [3] doesn't work for me
using Debian stable. I create Docker container with all dependencies but
make debball complain about missing sys/cdefs.h. I'm not sure what is
most recent way of building Xen on Debian. Also can try to rebuild
modified xen package for my rootfs, if you think it make sense.

If you have ideas how I can continue debugging of that issue or maybe
know what cause it please let me know.

[1] https://review.coreboot.org/#/c/coreboot/+/15164/
[2]
https://github.com/pcengines/apu2-documentation/blob/master/docs/logs/iommu_enabled_xl_dmesg.log
[3] https://wiki.xenproject.org/wiki/Compiling_Xen_From_Source

Best Regards,
--
Piotr Król
Embedded Systems Consultant
https://3mdeb.com | @3mdeb_com



_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xenproject.org/mailman/listinfo/xen-users