Compile Xen (unstable) with kernel 2.4 instead of 2.6.12

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Compile Xen (unstable) with kernel 2.4 instead of 2.6.12

cedric.jacquin




Hi,

I want tested Xen with my OS based on a kernel 2.4 (it's a CentOS 3.4).

I downloaded the unstable sources of xen (xen-unstable-src.tgz).
I read the user guide and I verified the "Prerequisites", I've :
      - the "iproute 2" package
      - the "linux bridge utils"
      - an installation of Twisted
      - gcc, binutils & make
      - curl-devel
      - zlib-devel
      - python
It's OK

I want build xen from source but I've a kernel 2.4 (kernel Redhat
2.4.21-27.0.2).
And when I compile, I've an error because it search a kernel 2.6.12

How to make to compile Xen with a kernel 2.4 ?



Regards,

Cédric


_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Compile Xen (unstable) with kernel 2.4 instead of 2.6.12

Dirk H. Schulz-2
Hi Cédric,

here you find an inspiring document:
http://wiki.blitzed.org/User:grifferz/Xen

You can use a vanilla kernel from kernel.org with that and can compile
2.4 or 2.6 or both (in the beginning just delete the kernel trees off
xen source you do not want to use).

Dirk

>
>
>Hi,
>
>I want tested Xen with my OS based on a kernel 2.4 (it's a CentOS 3.4).
>
>I downloaded the unstable sources of xen (xen-unstable-src.tgz).
>I read the user guide and I verified the "Prerequisites", I've :
>      - the "iproute 2" package
>      - the "linux bridge utils"
>      - an installation of Twisted
>      - gcc, binutils & make
>      - curl-devel
>      - zlib-devel
>      - python
>It's OK
>
>I want build xen from source but I've a kernel 2.4 (kernel Redhat
>2.4.21-27.0.2).
>And when I compile, I've an error because it search a kernel 2.6.12
>
>How to make to compile Xen with a kernel 2.4 ?
>
>
>
>Regards,
>
>Cédric
>
>
>_______________________________________________
>Xen-users mailing list
>[hidden email]
>http://lists.xensource.com/xen-users
>  
>


_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Compile Xen (unstable) with kernel 2.4 instead of 2.6.12

Lionel Bouton
Dirk H. Schulz wrote the following on 04.08.2005 13:27 :

> Hi Cédric,
>
> here you find an inspiring document:
> http://wiki.blitzed.org/User:grifferz/Xen
>
> You can use a vanilla kernel from kernel.org with that and can compile
> 2.4 or 2.6 or both (in the beginning just delete the kernel trees off
> xen source you do not want to use).
>
> Dirk


I may be mistaken, but I think I remember some posts about 2.4 support
being broken in the latest unstable snapshots. 2.0.7 should be fine
(2.0.6 surely is here).

Lionel.

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Compile Xen (unstable) with kernel 2.4 instead of 2.6.12

Mark Williamson
In reply to this post by cedric.jacquin
You can't use 2.4 as domain 0 (the "host") under the unstable tree.  If you
really want support for that, you should use the 2.0 tree.  You will be able
to run 2.4 as an unprivileged guest of another domain in the 3.0 release but
that's all - it was too much work maintaining the 2.4 dom0 support now that
2.4 is not used much anymore.

Cheers,
Mark

On Thursday 04 August 2005 11:48, [hidden email] wrote:

> Hi,
>
> I want tested Xen with my OS based on a kernel 2.4 (it's a CentOS 3.4).
>
> I downloaded the unstable sources of xen (xen-unstable-src.tgz).
> I read the user guide and I verified the "Prerequisites", I've :
>       - the "iproute 2" package
>       - the "linux bridge utils"
>       - an installation of Twisted
>       - gcc, binutils & make
>       - curl-devel
>       - zlib-devel
>       - python
> It's OK
>
> I want build xen from source but I've a kernel 2.4 (kernel Redhat
> 2.4.21-27.0.2).
> And when I compile, I've an error because it search a kernel 2.6.12
>
> How to make to compile Xen with a kernel 2.4 ?
>
>
>
> Regards,
>
> Cédric
>
>
> _______________________________________________
> Xen-users mailing list
> [hidden email]
> http://lists.xensource.com/xen-users

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users