Domain created twice ?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Domain created twice ?

Sylvain COUTANT

Hi all,

 

We ran into a strange problem today. One domain has been created twice. See "xm list" :

Name              Id  Mem(MB)  CPU  State  Time(s)  Console

Domain-0           0      251    0  r----    641.0

Domain-30         30       32    3  --p--      0.0

oe45              30       31    3  -b---      1.5    xx30

 

And xend.log :

 

[2005-08-22 00:58:25 xend] DEBUG (XendDomainInfo:720) init_domain> Created domain=30 name=oe45 memory=32

[2005-08-22 00:58:25 xend] INFO (console:94) Created console id=31 domain=30 port=xx30

[2005-08-22 00:58:25 xend] DEBUG (XendDomainInfo:1130) Creating vbd dom=30 uname=file: /xen/sde.swap

[2005-08-22 00:58:25 xend] DEBUG (blkif:155) Connecting blkif <BlkifBackendInterface 30 0>

[2005-08-22 00:58:25 xend] DEBUG (XendDomainInfo:1130) Creating vbd dom=30 uname=file:/xen/sda.data

[2005-08-22 00:58:25 xend] DEBUG (blkif:155) Connecting blkif <BlkifBackendInterface 30 0>

[2005-08-22 00:58:25 xend] DEBUG (XendDomainInfo:1107) Creating vif dom=30 vif=0 mac=aa:00:00:00:00:3f

[2005-08-22 00:58:26 xend] INFO (XendRoot:112) EVENT> xend.console.create [31, 30, xx30]

[2005-08-22 00:58:26 xend] INFO (XendRoot:112) EVENT> xend.domain.create ['Domain-30', '30']

[2005-08-22 00:58:26 xend] INFO (XendRoot:112) EVENT> xend.domain.died ['oe44', '25']

[2005-08-22 00:58:26 xend] INFO (XendRoot:112) EVENT> xend.domain.create ['oe45', '30']

[2005-08-22 00:58:26 xend] INFO (XendRoot:112) EVENT> xend.domain.unpause ['oe45', '30']

[2005-08-22 00:58:26 xend] DEBUG (blkif:203) Connecting blkif to event channel <BlkifBackendInterface 30 0> ports=32:3

 

 

Domain-30 has been automagically created while oe45 was starting !! Side effect is double :

-        console for oe45 is unaccessible,

-        destroying Domain-30 has destroyed oe45 also.

 

Xen is 2.0.6, Domain0 is 2.6.11.12 Debian Sarge. Xen tools are debian unstable .debs

 

Does anyone know the reason ?

 

We are unable to reproduce : it appeared at a time we were running some light stress tests (5-10 domu were starting/stopping).

 

 

Regards,

 

--

Sylvain COUTANT

 

ADVISEO

http://www.adviseo.fr/

http://www.open-sp.fr/


_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users