Fedora Core 5 boot problems

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Fedora Core 5 boot problems

Srinivasan S-2
Hi

I had Xen 2.x running peacefully on FC4 .. sigh.

Yesterday I upgraded to FC5 and also downloaded and installed the new Xen version 3.x from xensource.com .. I installed via the precompiled tarball.

My grub entries loook like this:

title Xen 3.0 (Fedora/XenLinux 2.6)
        root (hd0,4)
        kernel /xen.gz dom0_mem=260000
        module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
        module /initrd-2.6.15-1.2054_FC5.img
        boot

My /etc/fstab looks like this:

/dev/sda6                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/sda7               swap                    swap    defaults        0 0

...

Fedora is installed on a SATA hard disk, partition /dev/sda6

Xen boots and then soon after reports a kernel panic and after a few seconds reboots .. I was unable to get the messages before the last screen but managed to capture the last messages on screen .. reported below.

...
Loading jbd.ko module
jbd: disagrees about version of symbol struct_module
insmod: error inserting /lib/jbd.ko: -1 invalid module format
Loading ext3.ko module
ext3: disagrees about version of symbol struct_module
insmod: error inserting /lib/ext3.ko: -1 invalid module format
Creating root device
Mounting root filesystem
mount: could not find filesystem '/dev/root'
Setting up other filesystems
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: no such file or directory
setuproot: error mounting /sys: no such file or directory
Switching to new root and running init
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: no such file or directory
Kernel panic - not syncing: Attempted to kill Init:

And then the system quickly reboots.

Any help to fix this is appreciated.

Regards
Srini



--
_______________________________________________
Check out the latest SMS services @ http://www.linuxmail.org
This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

James Bulpin-2
You're using the kernel from the binary tarball and the initrd from the
FC5 non-Xen kernel. To a first approximation kernel version and modules
(in the initrd) must match.

James

Srinivasan S wrote:

> Hi
>
> I had Xen 2.x running peacefully on FC4 .. sigh.
>
> Yesterday I upgraded to FC5 and also downloaded and installed the new Xen version 3.x from xensource.com .. I installed via the precompiled tarball.
>
> My grub entries loook like this:
>
> title Xen 3.0 (Fedora/XenLinux 2.6)
> root (hd0,4)
> kernel /xen.gz dom0_mem=260000
> module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
> module /initrd-2.6.15-1.2054_FC5.img
> boot
>
> My /etc/fstab looks like this:
>
> /dev/sda6                 /                       ext3    defaults        1 1
> LABEL=/boot             /boot                   ext3    defaults        1 2
> none                    /dev/pts                devpts  gid=5,mode=620  0 0
> none                    /dev/shm                tmpfs   defaults        0 0
> none                    /proc                   proc    defaults        0 0
> none                    /sys                    sysfs   defaults        0 0
> /dev/sda7               swap                    swap    defaults        0 0
>
> ...
>
> Fedora is installed on a SATA hard disk, partition /dev/sda6
>
> Xen boots and then soon after reports a kernel panic and after a few seconds reboots .. I was unable to get the messages before the last screen but managed to capture the last messages on screen .. reported below.
>
> ...
> Loading jbd.ko module
> jbd: disagrees about version of symbol struct_module
> insmod: error inserting /lib/jbd.ko: -1 invalid module format
> Loading ext3.ko module
> ext3: disagrees about version of symbol struct_module
> insmod: error inserting /lib/ext3.ko: -1 invalid module format
> Creating root device
> Mounting root filesystem
> mount: could not find filesystem '/dev/root'
> Setting up other filesystems
> Setting up new root fs
> setuproot: moving /dev failed: No such file or directory
> no fstab.sys, mounting internal defaults
> setuproot: error mounting /proc: no such file or directory
> setuproot: error mounting /sys: no such file or directory
> Switching to new root and running init
> unmounting old /dev
> unmounting old /proc
> unmounting old /sys
> switchroot: mount failed: no such file or directory
> Kernel panic - not syncing: Attempted to kill Init:
>
> And then the system quickly reboots.
>
> Any help to fix this is appreciated.
>
> Regards
> Srini
>
>
>

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

James Bulpin-2
In reply to this post by Srinivasan S-2
If you install from tarball you need to create this yourself, e.g.:

   /sbin/mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen

(and update grub)

The install.sh script does not do this automagically because initrd
generation is distribution-specific.

James

Srinivasan S wrote:

> Thanks for a prompt response ..
>
> I could not find any initrd for the Xen 3.o in my /boot ..
> Do I need to do a mkinitrd ?  Any hints will help
>
> Regards
> Srini
>
>
>>----- Original Message -----
>>From: "James Bulpin" <[hidden email]>
>>To: "Srinivasan S" <[hidden email]>
>>Subject: Re: [Xen-users] Fedora Core 5 boot problems
>>Date: Fri, 14 Apr 2006 14:37:05 +0100
>>
>>
>>You're using the kernel from the binary tarball and the initrd from
>>the FC5 non-Xen kernel. To a first approximation kernel version and
>>modules (in the initrd) must match.
>>
>>James
>>
>>Srinivasan S wrote:
>>
>>>Hi
>>>
>>>I had Xen 2.x running peacefully on FC4 .. sigh.
>>>
>>>Yesterday I upgraded to FC5 and also downloaded and installed the
>>>new Xen version 3.x from xensource.com .. I installed via the
>>>precompiled tarball.
>>>
>>>My grub entries loook like this:
>>>
>>>title Xen 3.0 (Fedora/XenLinux 2.6)
>>> root (hd0,4)
>>> kernel /xen.gz dom0_mem=260000
>>> module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
>>> module /initrd-2.6.15-1.2054_FC5.img
>>> boot
>>>
>>>My /etc/fstab looks like this:
>>>
>>>/dev/sda6                 /                       ext3    defaults        1 1
>>>LABEL=/boot             /boot                   ext3    defaults        1 2
>>>none                    /dev/pts                devpts  gid=5,mode=620  0 0
>>>none                    /dev/shm                tmpfs   defaults        0 0
>>>none                    /proc                   proc    defaults        0 0
>>>none                    /sys                    sysfs   defaults        0 0
>>>/dev/sda7               swap                    swap    defaults        0 0
>>>
>>>...
>>>
>>>Fedora is installed on a SATA hard disk, partition /dev/sda6
>>>
>>>Xen boots and then soon after reports a kernel panic and after a
>>>few seconds reboots .. I was unable to get the messages before
>>>the last screen but managed to capture the last messages on
>>>screen .. reported below.
>>>
>>>...
>>>Loading jbd.ko module
>>>jbd: disagrees about version of symbol struct_module
>>>insmod: error inserting /lib/jbd.ko: -1 invalid module format
>>>Loading ext3.ko module
>>>ext3: disagrees about version of symbol struct_module
>>>insmod: error inserting /lib/ext3.ko: -1 invalid module format
>>>Creating root device
>>>Mounting root filesystem
>>>mount: could not find filesystem '/dev/root'
>>>Setting up other filesystems
>>>Setting up new root fs
>>>setuproot: moving /dev failed: No such file or directory
>>>no fstab.sys, mounting internal defaults
>>>setuproot: error mounting /proc: no such file or directory
>>>setuproot: error mounting /sys: no such file or directory
>>>Switching to new root and running init
>>>unmounting old /dev
>>>unmounting old /proc
>>>unmounting old /sys
>>>switchroot: mount failed: no such file or directory
>>>Kernel panic - not syncing: Attempted to kill Init:
>>>
>>>And then the system quickly reboots.
>>>
>>>Any help to fix this is appreciated.
>>>
>>>Regards
>>>Srini
>>>
>>>
>>>
>
>
>
>

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

Eric Wagar
I've just installed from the tarball install.sh also and have the same
issue.  (Mine is on RHEL4U2 on x86_64.)

When I tried the mkinitrd, I get this error:
[root@stone-age-global /]# /sbin/mkinitrd /boot/initrd-2.6.16-xen.img
2.6.16-xen
No dep file found for kernel 2.6.16-xen

After looking through the other kernels I have, it seems as though they
have them.

What is the workaround here?  Do we just copy over the other deps and
modify them for 2.6.16-xen?

Thanks
eric

On Fri, 14 Apr 2006 14:56:27 +0100, "James Bulpin" <[hidden email]>
said:

> If you install from tarball you need to create this yourself, e.g.:
>
>    /sbin/mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen
>
> (and update grub)
>
> The install.sh script does not do this automagically because initrd
> generation is distribution-specific.
>
> James
>
> Srinivasan S wrote:
> > Thanks for a prompt response ..
> >
> > I could not find any initrd for the Xen 3.o in my /boot ..
> > Do I need to do a mkinitrd ?  Any hints will help
> >
> > Regards
> > Srini
> >
> >
> >>----- Original Message -----
> >>From: "James Bulpin" <[hidden email]>
> >>To: "Srinivasan S" <[hidden email]>
> >>Subject: Re: [Xen-users] Fedora Core 5 boot problems
> >>Date: Fri, 14 Apr 2006 14:37:05 +0100
> >>
> >>
> >>You're using the kernel from the binary tarball and the initrd from
> >>the FC5 non-Xen kernel. To a first approximation kernel version and
> >>modules (in the initrd) must match.
> >>
> >>James
> >>
> >>Srinivasan S wrote:
> >>
> >>>Hi
> >>>
> >>>I had Xen 2.x running peacefully on FC4 .. sigh.
> >>>
> >>>Yesterday I upgraded to FC5 and also downloaded and installed the
> >>>new Xen version 3.x from xensource.com .. I installed via the
> >>>precompiled tarball.
> >>>
> >>>My grub entries loook like this:
> >>>
> >>>title Xen 3.0 (Fedora/XenLinux 2.6)
> >>> root (hd0,4)
> >>> kernel /xen.gz dom0_mem=260000
> >>> module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
> >>> module /initrd-2.6.15-1.2054_FC5.img
> >>> boot
> >>>
> >>>My /etc/fstab looks like this:
> >>>
> >>>/dev/sda6                 /                       ext3    defaults        1 1
> >>>LABEL=/boot             /boot                   ext3    defaults        1 2
> >>>none                    /dev/pts                devpts  gid=5,mode=620  0 0
> >>>none                    /dev/shm                tmpfs   defaults        0 0
> >>>none                    /proc                   proc    defaults        0 0
> >>>none                    /sys                    sysfs   defaults        0 0
> >>>/dev/sda7               swap                    swap    defaults        0 0
> >>>
> >>>...
> >>>
> >>>Fedora is installed on a SATA hard disk, partition /dev/sda6
> >>>
> >>>Xen boots and then soon after reports a kernel panic and after a
> >>>few seconds reboots .. I was unable to get the messages before
> >>>the last screen but managed to capture the last messages on
> >>>screen .. reported below.
> >>>
> >>>...
> >>>Loading jbd.ko module
> >>>jbd: disagrees about version of symbol struct_module
> >>>insmod: error inserting /lib/jbd.ko: -1 invalid module format
> >>>Loading ext3.ko module
> >>>ext3: disagrees about version of symbol struct_module
> >>>insmod: error inserting /lib/ext3.ko: -1 invalid module format
> >>>Creating root device
> >>>Mounting root filesystem
> >>>mount: could not find filesystem '/dev/root'
> >>>Setting up other filesystems
> >>>Setting up new root fs
> >>>setuproot: moving /dev failed: No such file or directory
> >>>no fstab.sys, mounting internal defaults
> >>>setuproot: error mounting /proc: no such file or directory
> >>>setuproot: error mounting /sys: no such file or directory
> >>>Switching to new root and running init
> >>>unmounting old /dev
> >>>unmounting old /proc
> >>>unmounting old /sys
> >>>switchroot: mount failed: no such file or directory
> >>>Kernel panic - not syncing: Attempted to kill Init:
> >>>
> >>>And then the system quickly reboots.
> >>>
> >>>Any help to fix this is appreciated.
> >>>
> >>>Regards
> >>>Srini
> >>>
> >>>
> >>>
> >
> >
> >
> >
>
> _______________________________________________
> Xen-users mailing list
> [hidden email]
> http://lists.xensource.com/xen-users

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

Srinivasan S-2
In reply to this post by Srinivasan S-2
I just tried copying the modules.dep file from the stock FC5 kernel .. mkinitird is successful .

The system boots also using the initrd produced ..

However the network modules are disabled and both eth0 and eth1 are not enabled.  Strange since everything works with the stock kernel ..

I guess some more work needs to be done on the modules.dep file ..

Can someone please help ?

Regards
Srini

>I've just installed from the tarball install.sh also >and have the same
>issue.  (Mine is on RHEL4U2 on x86_64.)

>When I tried the mkinitrd, I get this error:
>[root@stone-age-global /]# /sbin/mkinitrd >/boot/initrd-2.6.16-xen.img
>2.6.16-xen
>No dep file found for kernel 2.6.16-xen

>After looking through the other kernels I have, it >seems as though they
>have them.

>What is the workaround here?  Do we just copy over >the other deps and
>modify them for 2.6.16-xen?

>Thanks
>eric

> ----- Original Message -----
> From: "James Bulpin" <[hidden email]>
> To: "Srinivasan S" <[hidden email]>
> Subject: Re: [Xen-users] Fedora Core 5 boot problems
> Date: Fri, 14 Apr 2006 14:56:27 +0100
>
>
> If you install from tarball you need to create this yourself, e.g.:
>
>    /sbin/mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen
>
> (and update grub)
>
> The install.sh script does not do this automagically because initrd
> generation is distribution-specific.
>
> James
>
> Srinivasan S wrote:
> > Thanks for a prompt response ..
> >
> > I could not find any initrd for the Xen 3.o in my /boot ..
> > Do I need to do a mkinitrd ?  Any hints will help
> >
> > Regards
> > Srini
> >
> >
> >> ----- Original Message -----
> >> From: "James Bulpin" <[hidden email]>
> >> To: "Srinivasan S" <[hidden email]>
> >> Subject: Re: [Xen-users] Fedora Core 5 boot problems
> >> Date: Fri, 14 Apr 2006 14:37:05 +0100
> >>
> >>
> >> You're using the kernel from the binary tarball and the initrd
> >> from the FC5 non-Xen kernel. To a first approximation kernel
> >> version and modules (in the initrd) must match.
> >>
> >> James
> >>
> >> Srinivasan S wrote:
> >>
> >>> Hi
> >>>
> >>> I had Xen 2.x running peacefully on FC4 .. sigh.
> >>>
> >>> Yesterday I upgraded to FC5 and also downloaded and installed
> >>> the new Xen version 3.x from xensource.com .. I installed via
> >>> the precompiled tarball.
> >>>
> >>> My grub entries loook like this:
> >>>
> >>> title Xen 3.0 (Fedora/XenLinux 2.6)
> >>> root (hd0,4)
> >>> kernel /xen.gz dom0_mem=260000
> >>> module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
> >>> module /initrd-2.6.15-1.2054_FC5.img
> >>> boot
> >>>
> >>> My /etc/fstab looks like this:
> >>>
> >>> /dev/sda6                 /                       ext3    
> >>> defaults        1 1
> >>> LABEL=/boot             /boot                   ext3    defaults        1 2
> >>> none                    /dev/pts                devpts  gid=5,mode=620  0 0
> >>> none                    /dev/shm                tmpfs   defaults        0 0
> >>> none                    /proc                   proc    defaults        0 0
> >>> none                    /sys                    sysfs   defaults        0 0
> >>> /dev/sda7               swap                    swap    defaults        0 0
> >>>
> >>> ...
> >>>
> >>> Fedora is installed on a SATA hard disk, partition /dev/sda6
> >>>
> >>> Xen boots and then soon after reports a kernel panic and after
> >>> a few seconds reboots .. I was unable to get the messages
> >>> before the last screen but managed to capture the last messages
> >>> on screen .. reported below.
> >>>
> >>> ...
> >>> Loading jbd.ko module
> >>> jbd: disagrees about version of symbol struct_module
> >>> insmod: error inserting /lib/jbd.ko: -1 invalid module format
> >>> Loading ext3.ko module
> >>> ext3: disagrees about version of symbol struct_module
> >>> insmod: error inserting /lib/ext3.ko: -1 invalid module format
> >>> Creating root device
> >>> Mounting root filesystem
> >>> mount: could not find filesystem '/dev/root'
> >>> Setting up other filesystems
> >>> Setting up new root fs
> >>> setuproot: moving /dev failed: No such file or directory
> >>> no fstab.sys, mounting internal defaults
> >>> setuproot: error mounting /proc: no such file or directory
> >>> setuproot: error mounting /sys: no such file or directory
> >>> Switching to new root and running init
> >>> unmounting old /dev
> >>> unmounting old /proc
> >>> unmounting old /sys
> >>> switchroot: mount failed: no such file or directory
> >>> Kernel panic - not syncing: Attempted to kill Init:
> >>>
> >>> And then the system quickly reboots.
> >>>
> >>> Any help to fix this is appreciated.
> >>>
> >>> Regards
> >>> Srini
> >>>
> >>>
> >>>
> >
> >
> >
> >

>


--
_______________________________________________
Check out the latest SMS services @ http://www.linuxmail.org
This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

Srinivasan S-2
In reply to this post by Srinivasan S-2
OK, I got it running ...

I first executed : depmod 2.6.16-xen and this generated the required modules.dep and other files.

Then I executed : mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen and this generated the proper initrd file

And voila the boot worked perfectly and my xen dom0 is atleast running .. Now to get domU ;-)

Thanks to James for pointing me in the right direction

Cheers
Srini

>I just tried copying the modules.dep file from the stock FC5 kernel ..
>mkinitird is successful .
>
>The system boots also using the initrd produced ..
>
>However the network modules are disabled and both eth0 and eth1 are not
>enabled.  Strange since everything works with the stock kernel ..
>
>I guess some more work needs to be done on the modules.dep file ..
>
>Can someone please help ?
>
>Regards
>Srini

>I've just installed from the tarball install.sh also >and have the same
>issue.  (Mine is on RHEL4U2 on x86_64.)

>When I tried the mkinitrd, I get this error:
>[root@stone-age-global /]# /sbin/mkinitrd >/boot/initrd-2.6.16-xen.img
>2.6.16-xen
>No dep file found for kernel 2.6.16-xen

>After looking through the other kernels I have, it >seems as though they
>have them.

>What is the workaround here?  Do we just copy over >the other deps and
>modify them for 2.6.16-xen?

>Thanks
>eric

> ----- Original Message -----
> From: "James Bulpin" <james@xxxxxxxxxxxxx>
> To: "Srinivasan S" <ssrini@xxxxxxxxxxxxx>
> Subject: Re: [Xen-users] Fedora Core 5 boot problems
> Date: Fri, 14 Apr 2006 14:56:27 +0100
>
>
> If you install from tarball you need to create this yourself, e.g.:
>
>    /sbin/mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen
>
> (and update grub)
>
> The install.sh script does not do this automagically because initrd
> generation is distribution-specific.
>
> James
>
> Srinivasan S wrote:
> > Thanks for a prompt response ..
> >
> > I could not find any initrd for the Xen 3.o in my /boot ..
> > Do I need to do a mkinitrd ?  Any hints will help
> >
> > Regards
> > Srini
> >
> >
> >> ----- Original Message -----
> >> From: "James Bulpin" <james@xxxxxxxxxxxxx>
> >> To: "Srinivasan S" <ssrini@xxxxxxxxxxxxx>
> >> Subject: Re: [Xen-users] Fedora Core 5 boot problems
> >> Date: Fri, 14 Apr 2006 14:37:05 +0100
> >>
> >>
> >> You're using the kernel from the binary tarball and the initrd
> >> from the FC5 non-Xen kernel. To a first approximation kernel
> >> version and modules (in the initrd) must match.
> >>
> >> James
> >>
> >> Srinivasan S wrote:
> >>
> >>> Hi
> >>>
> >>> I had Xen 2.x running peacefully on FC4 .. sigh.
> >>>
> >>> Yesterday I upgraded to FC5 and also downloaded and installed
> >>> the new Xen version 3.x from xensource.com .. I installed via
> >>> the precompiled tarball.
> >>>
> >>> My grub entries loook like this:
> >>>
> >>> title Xen 3.0 (Fedora/XenLinux 2.6)
> >>>   root (hd0,4)
> >>>   kernel /xen.gz dom0_mem=260000
> >>>   module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
> >>>   module /initrd-2.6.15-1.2054_FC5.img
> >>>   boot
> >>>
> >>> My /etc/fstab looks like this:
> >>>
> >>> /dev/sda6                 /                       ext3    
> >>> defaults        1 1
> >>> LABEL=/boot             /boot                   ext3    defaults        1
> >>> 2
> >>> none                    /dev/pts                devpts  gid=5,mode=620  0 > >>> 0
> >>> none                    /dev/shm                tmpfs   defaults        0 > >>> 0
> >>> none                    /proc                   proc    defaults        0 > >>> 0
> >>> none                    /sys                    sysfs   defaults        0 > >>> 0
> >>> /dev/sda7               swap                    swap    defaults        0 > >>> 0
> >>>
> >>> ...
> >>>
> >>> Fedora is installed on a SATA hard disk, partition /dev/sda6
> >>>
> >>> Xen boots and then soon after reports a kernel panic and after
> >>> a few seconds reboots .. I was unable to get the messages
> >>> before the last screen but managed to capture the last messages
> >>> on screen .. reported below.
> >>>
> >>> ...
> >>> Loading jbd.ko module
> >>> jbd: disagrees about version of symbol struct_module
> >>> insmod: error inserting /lib/jbd.ko: -1 invalid module format
> >>> Loading ext3.ko module
> >>> ext3: disagrees about version of symbol struct_module
> >>> insmod: error inserting /lib/ext3.ko: -1 invalid module format
> >>> Creating root device
> >>> Mounting root filesystem
> >>> mount: could not find filesystem '/dev/root'
> >>> Setting up other filesystems
> >>> Setting up new root fs
> >>> setuproot: moving /dev failed: No such file or directory
> >>> no fstab.sys, mounting internal defaults
> >>> setuproot: error mounting /proc: no such file or directory
> >>> setuproot: error mounting /sys: no such file or directory
> >>> Switching to new root and running init
> >>> unmounting old /dev
> >>> unmounting old /proc
> >>> unmounting old /sys
> >>> switchroot: mount failed: no such file or directory
> >>> Kernel panic - not syncing: Attempted to kill Init:
> >>>
> >>> And then the system quickly reboots.
> >>>
> >>> Any help to fix this is appreciated.
> >>>
> >>> Regards
> >>> Srini
> >>>
> >>>
> >>>
> >
> >
> >
> >

>


--

--
_______________________________________________
Check out the latest SMS services @ http://www.linuxmail.org
This allows you to send and receive SMS through your mailbox.

Powered by Outblaze

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Fedora Core 5 boot problems

James Bulpin-2
In reply to this post by Srinivasan S-2
Please include the list on your replies, I'm out of town at the moment
so you'll probably get quicker responses from others on the list.

You need to run e.g.:

depmod -a 2.6.16-xen

(This is the same procedure you would use to install any new Kernel, Xen
or otherwise.)

James

Srinivasan S wrote:

> Hi James
>
> I tried this and got the error message ..
>
> No dep file found for kernel
>
> I then tried copying the modules.dep file from the stock fc5 kernel and tried mkinitrd again. It went through and created the initrd.  
>
> I then tried booting with the new initrd .. it works but a number of modules .. espescially network interfaces (eth0, eth1) do not load and produce errors.
>
> Any idea where I need to get the modules.dep file from ?  Or am I missing something else ?
>
> Cheers
> Srini
>
>>----- Original Message -----
>>From: "James Bulpin" <[hidden email]>
>>To: "Srinivasan S" <[hidden email]>
>>Subject: Re: [Xen-users] Fedora Core 5 boot problems
>>Date: Fri, 14 Apr 2006 14:56:27 +0100
>>
>>
>>If you install from tarball you need to create this yourself, e.g.:
>>
>>   /sbin/mkinitrd /boot/initrd-2.6.16-xen.img 2.6.16-xen
>>
>>(and update grub)
>>
>>The install.sh script does not do this automagically because initrd
>>generation is distribution-specific.
>>
>>James
>>
>>Srinivasan S wrote:
>>
>>>Thanks for a prompt response ..
>>>
>>>I could not find any initrd for the Xen 3.o in my /boot ..
>>>Do I need to do a mkinitrd ?  Any hints will help
>>>
>>>Regards
>>>Srini
>>>
>>>
>>>
>>>>----- Original Message -----
>>>>From: "James Bulpin" <[hidden email]>
>>>>To: "Srinivasan S" <[hidden email]>
>>>>Subject: Re: [Xen-users] Fedora Core 5 boot problems
>>>>Date: Fri, 14 Apr 2006 14:37:05 +0100
>>>>
>>>>
>>>>You're using the kernel from the binary tarball and the initrd
>>>>from the FC5 non-Xen kernel. To a first approximation kernel
>>>>version and modules (in the initrd) must match.
>>>>
>>>>James
>>>>
>>>>Srinivasan S wrote:
>>>>
>>>>
>>>>>Hi
>>>>>
>>>>>I had Xen 2.x running peacefully on FC4 .. sigh.
>>>>>
>>>>>Yesterday I upgraded to FC5 and also downloaded and installed
>>>>>the new Xen version 3.x from xensource.com .. I installed via
>>>>>the precompiled tarball.
>>>>>
>>>>>My grub entries loook like this:
>>>>>
>>>>>title Xen 3.0 (Fedora/XenLinux 2.6)
>>>>> root (hd0,4)
>>>>> kernel /xen.gz dom0_mem=260000
>>>>> module /vmlinuz-2.6-xen root=/dev/sda6 ro console=tty0
>>>>> module /initrd-2.6.15-1.2054_FC5.img
>>>>> boot
>>>>>
>>>>>My /etc/fstab looks like this:
>>>>>
>>>>>/dev/sda6                 /                       ext3    
>>>>>defaults        1 1
>>>>>LABEL=/boot             /boot                   ext3    defaults        1 2
>>>>>none                    /dev/pts                devpts  gid=5,mode=620  0 0
>>>>>none                    /dev/shm                tmpfs   defaults        0 0
>>>>>none                    /proc                   proc    defaults        0 0
>>>>>none                    /sys                    sysfs   defaults        0 0
>>>>>/dev/sda7               swap                    swap    defaults        0 0
>>>>>
>>>>>...
>>>>>
>>>>>Fedora is installed on a SATA hard disk, partition /dev/sda6
>>>>>
>>>>>Xen boots and then soon after reports a kernel panic and after
>>>>>a few seconds reboots .. I was unable to get the messages
>>>>>before the last screen but managed to capture the last messages
>>>>>on screen .. reported below.
>>>>>
>>>>>...
>>>>>Loading jbd.ko module
>>>>>jbd: disagrees about version of symbol struct_module
>>>>>insmod: error inserting /lib/jbd.ko: -1 invalid module format
>>>>>Loading ext3.ko module
>>>>>ext3: disagrees about version of symbol struct_module
>>>>>insmod: error inserting /lib/ext3.ko: -1 invalid module format
>>>>>Creating root device
>>>>>Mounting root filesystem
>>>>>mount: could not find filesystem '/dev/root'
>>>>>Setting up other filesystems
>>>>>Setting up new root fs
>>>>>setuproot: moving /dev failed: No such file or directory
>>>>>no fstab.sys, mounting internal defaults
>>>>>setuproot: error mounting /proc: no such file or directory
>>>>>setuproot: error mounting /sys: no such file or directory
>>>>>Switching to new root and running init
>>>>>unmounting old /dev
>>>>>unmounting old /proc
>>>>>unmounting old /sys
>>>>>switchroot: mount failed: no such file or directory
>>>>>Kernel panic - not syncing: Attempted to kill Init:
>>>>>
>>>>>And then the system quickly reboots.
>>>>>
>>>>>Any help to fix this is appreciated.
>>>>>
>>>>>Regards
>>>>>Srini
>>>>>
>>>>>
>>>>>
>>>
>>>
>>>
>>>
>
>
>

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users