Fedora guest not detecting virtual disk

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fedora guest not detecting virtual disk

Julian DeMille
After I migrated a Fedora VM from vSphere to Xen, the VM stopped recognizing any disks I attach to it. When in the Dracut recovery terminal, there are no signs of virtual disks on the VM. No xvd*, no sd*, only sr0. How can I troubleshoot this?

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fedora guest not detecting virtual disk

WebDawg
How are you attaching the disk?

On Aug 5, 2017 12:38 PM, "Julian DeMille" <[hidden email]> wrote:
After I migrated a Fedora VM from vSphere to Xen, the VM stopped recognizing any disks I attach to it. When in the Dracut recovery terminal, there are no signs of virtual disks on the VM. No xvd*, no sd*, only sr0. How can I troubleshoot this?

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fedora guest not detecting virtual disk

Julian DeMille
I am adding it to the VM. What confuses me is that an Ubuntu live ISO guest can read the disk just fine. Is it some weird driver issue?

On Sat, Aug 5, 2017 at 2:10 PM, WebDawg <[hidden email]> wrote:
How are you attaching the disk?

On Aug 5, 2017 12:38 PM, "Julian DeMille" <[hidden email]> wrote:
After I migrated a Fedora VM from vSphere to Xen, the VM stopped recognizing any disks I attach to it. When in the Dracut recovery terminal, there are no signs of virtual disks on the VM. No xvd*, no sd*, only sr0. How can I troubleshoot this?

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users



--
Julian DeMille

CEO, demilleTech Flight Simulations, LLC.

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fedora guest not detecting virtual disk

WebDawg
How old is the fedora vm, what software are you using to attach?  Command line?

Is this xen?  XenServer?

What version of Xen?

On Sat, Aug 5, 2017 at 2:12 PM, Julian DeMille
<[hidden email]> wrote:

> I am adding it to the VM. What confuses me is that an Ubuntu live ISO guest
> can read the disk just fine. Is it some weird driver issue?
>
> On Sat, Aug 5, 2017 at 2:10 PM, WebDawg <[hidden email]> wrote:
>>
>> How are you attaching the disk?
>>
>> On Aug 5, 2017 12:38 PM, "Julian DeMille" <[hidden email]>
>> wrote:
>>>
>>> After I migrated a Fedora VM from vSphere to Xen, the VM stopped
>>> recognizing any disks I attach to it. When in the Dracut recovery terminal,
>>> there are no signs of virtual disks on the VM. No xvd*, no sd*, only sr0.
>>> How can I troubleshoot this?
>>>
>>> _______________________________________________
>>> Xen-users mailing list
>>> [hidden email]
>>> https://lists.xen.org/xen-users
>
>
>
>
> --
> Julian DeMille
>
> CEO, demilleTech Flight Simulations, LLC.
>
> This email and any files transmitted with it are confidential and intended
> solely for the use of the individual or entity to whom they are addressed.
> If you have received this email in error please notify the system manager.
> This message contains confidential information and is intended only for the
> individual named. If you are not the named addressee you should not
> disseminate, distribute or copy this e-mail. Please notify the sender
> immediately by e-mail if you have received this e-mail by mistake and delete
> this e-mail from your system. If you are not the intended recipient you are
> notified that disclosing, copying, distributing or taking any action in
> reliance on the contents of this information is strictly prohibited.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fedora guest not detecting virtual disk

Julian DeMille
It's a Fedora 25 VM, a couple months old. I'm using XenServer and XenCenter to attach the disk.

On Mon, Aug 7, 2017 at 13:22 WebDawg <[hidden email]> wrote:
How old is the fedora vm, what software are you using to attach?  Command line?

Is this xen?  XenServer?

What version of Xen?

On Sat, Aug 5, 2017 at 2:12 PM, Julian DeMille
<[hidden email]> wrote:
> I am adding it to the VM. What confuses me is that an Ubuntu live ISO guest
> can read the disk just fine. Is it some weird driver issue?
>
> On Sat, Aug 5, 2017 at 2:10 PM, WebDawg <[hidden email]> wrote:
>>
>> How are you attaching the disk?
>>
>> On Aug 5, 2017 12:38 PM, "Julian DeMille" <[hidden email]>
>> wrote:
>>>
>>> After I migrated a Fedora VM from vSphere to Xen, the VM stopped
>>> recognizing any disks I attach to it. When in the Dracut recovery terminal,
>>> there are no signs of virtual disks on the VM. No xvd*, no sd*, only sr0.
>>> How can I troubleshoot this?
>>>
>>> _______________________________________________
>>> Xen-users mailing list
>>> [hidden email]
>>> https://lists.xen.org/xen-users
>
>
>
>
> --
> Julian DeMille
>
> CEO, demilleTech Flight Simulations, LLC.
>
> This email and any files transmitted with it are confidential and intended
> solely for the use of the individual or entity to whom they are addressed.
> If you have received this email in error please notify the system manager.
> This message contains confidential information and is intended only for the
> individual named. If you are not the named addressee you should not
> disseminate, distribute or copy this e-mail. Please notify the sender
> immediately by e-mail if you have received this e-mail by mistake and delete
> this e-mail from your system. If you are not the intended recipient you are
> notified that disclosing, copying, distributing or taking any action in
> reliance on the contents of this information is strictly prohibited.
--
Julian DeMille

CEO, demilleTech Flight Simulations, LLC.

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fedora guest not detecting virtual disk

WebDawg
It has been a real long time since I used XenCenter.  Are you using
the windows official version, is it up to date?  What version of
XenServer are you using?

I think if I remember correctly you had to attach the disk and then
activate it in the GUI interface, or I could be thinking of taking the
disk out...I would have to deactivate, and then unplug.

Also it should pop up as an xvdX device...and most of the time it pops
up as root, so make sure to check as root.

I have not used fedora in a long time, I do not know how it would set
the permissions of a xen device on hotplug.

I would think this does not matter much, but did you install Fedora in
paravirtualization mode?  When you selected a template, did you select
fedora or Other?

Try an install w/ other and get into full HVM mode...most linux now a
days has pv hvm stuff built in so...

Last time I used it, it seemed to work great though.

Can you try https://xen-orchestra.com/ and see if you have the same issue?

Sorry I cannot be of anymore help.

Your best bet at this point is to find the logs
(https://xenserver.org/partners/developing-products-for-xenserver/20-dev-hints/90-xs-log-debug-understand.html)
that would output the messages that have to do with what you are
doing.

I would look into the logs:

ssh into the box ssh xenserver.domain -lroot

cd /var/log

tail -f xensource.log

Then try and attach the disk and see what happens.

If you take a look at xen-orchestra it can do all the software
patching for xenserver too for you, you may need a patch or something.



On Mon, Aug 7, 2017 at 1:27 PM, Julian DeMille
<[hidden email]> wrote:

> It's a Fedora 25 VM, a couple months old. I'm using XenServer and XenCenter
> to attach the disk.
>
> On Mon, Aug 7, 2017 at 13:22 WebDawg <[hidden email]> wrote:
>>
>> How old is the fedora vm, what software are you using to attach?  Command
>> line?
>>
>> Is this xen?  XenServer?
>>
>> What version of Xen?
>>
>> On Sat, Aug 5, 2017 at 2:12 PM, Julian DeMille
>> <[hidden email]> wrote:
>> > I am adding it to the VM. What confuses me is that an Ubuntu live ISO
>> > guest
>> > can read the disk just fine. Is it some weird driver issue?
>> >
>> > On Sat, Aug 5, 2017 at 2:10 PM, WebDawg <[hidden email]> wrote:
>> >>
>> >> How are you attaching the disk?
>> >>
>> >> On Aug 5, 2017 12:38 PM, "Julian DeMille"
>> >> <[hidden email]>
>> >> wrote:
>> >>>
>> >>> After I migrated a Fedora VM from vSphere to Xen, the VM stopped
>> >>> recognizing any disks I attach to it. When in the Dracut recovery
>> >>> terminal,
>> >>> there are no signs of virtual disks on the VM. No xvd*, no sd*, only
>> >>> sr0.
>> >>> How can I troubleshoot this?
>> >>>
>> >>> _______________________________________________
>> >>> Xen-users mailing list
>> >>> [hidden email]
>> >>> https://lists.xen.org/xen-users
>> >
>> >
>> >
>> >
>> > --
>> > Julian DeMille
>> >
>> > CEO, demilleTech Flight Simulations, LLC.
>> >
>> > This email and any files transmitted with it are confidential and
>> > intended
>> > solely for the use of the individual or entity to whom they are
>> > addressed.
>> > If you have received this email in error please notify the system
>> > manager.
>> > This message contains confidential information and is intended only for
>> > the
>> > individual named. If you are not the named addressee you should not
>> > disseminate, distribute or copy this e-mail. Please notify the sender
>> > immediately by e-mail if you have received this e-mail by mistake and
>> > delete
>> > this e-mail from your system. If you are not the intended recipient you
>> > are
>> > notified that disclosing, copying, distributing or taking any action in
>> > reliance on the contents of this information is strictly prohibited.
>
> --
> Julian DeMille
>
> CEO, demilleTech Flight Simulations, LLC.
>
> This email and any files transmitted with it are confidential and intended
> solely for the use of the individual or entity to whom they are addressed.
> If you have received this email in error please notify the system manager.
> This message contains confidential information and is intended only for the
> individual named. If you are not the named addressee you should not
> disseminate, distribute or copy this e-mail. Please notify the sender
> immediately by e-mail if you have received this e-mail by mistake and delete
> this e-mail from your system. If you are not the intended recipient you are
> notified that disclosing, copying, distributing or taking any action in
> reliance on the contents of this information is strictly prohibited.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Loading...