Kernel panic, unable to mount rootfs

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Kernel panic, unable to mount rootfs

Matthew J. Harmon
Alright, thank you for the "noreboot" kernel option!

Here is the full err:

Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "sda2" or unknown-block(2,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(2,0)

Doing a bit of research on the error message, found the following threads
on xen-devel:
http://lists.xensource.com/archives/html/xen-devel/2004-10/msg00382.html
http://lists.xensource.com/archives/html/xen-devel/2004-12/msg00470.html

I'm thinking this might not be a xen problem, but a grub problem?

Still working on the issue, any tips would be appreciated.

Thanks.

-Matthew

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Kernel panic, unable to mount rootfs

Matthew J. Harmon
Additionally, the menu.lst for grub is as follows:

title Debian GNU/Linux, Xen 2.6.11xen0, testing 2005.06.18
kernel=/xen.gz dom0_mem=32768 noreboot
root (hd0,0)
module=(hd0,0)/xen-linux-2.6.11charliexen0 root=/dev/sda2 ro console=tty0
console=ttyS0 showopts selinux=0
### BEGIN AUTOMAGIC KERNELS LIST
###[snip - all default]

-M

On Mon, 20 Jun 2005, Matthew J. Harmon wrote:

Alright, thank you for the "noreboot" kernel option!

Here is the full err:

Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "sda2" or unknown-block(2,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

Doing a bit of research on the error message, found the following threads on
xen-devel:
http://lists.xensource.com/archives/html/xen-devel/2004-10/msg00382.html
http://lists.xensource.com/archives/html/xen-devel/2004-12/msg00470.html

I'm thinking this might not be a xen problem, but a grub problem?

Still working on the issue, any tips would be appreciated.

Thanks.

-Matthew

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: Re: Kernel panic, unable to mount rootfs

Yvette Chanco
If you're getting that far (to starting the dom0) then grub might not
directly be the issue. I got that error message when I was using a
kernel (for dom0) that hadn't been compiled with support for my scsi
adapter. From the looks of your menu.lst, though, it seems you
probably did a custom build, so you would know what you included. My
only other guess is if there is an initrd image you haven't put in the
grub configuration?

On 6/20/05, Matthew J. Harmon <[hidden email]> wrote:

> Additionally, the menu.lst for grub is as follows:
>
> title Debian GNU/Linux, Xen 2.6.11xen0, testing 2005.06.18
> kernel=/xen.gz dom0_mem=32768 noreboot
> root (hd0,0)
> module=(hd0,0)/xen-linux-2.6.11charliexen0 root=/dev/sda2 ro console=tty0
> console=ttyS0 showopts selinux=0
> ### BEGIN AUTOMAGIC KERNELS LIST
> ###[snip - all default]
>
> -M
>
> On Mon, 20 Jun 2005, Matthew J. Harmon wrote:
>
> Alright, thank you for the "noreboot" kernel option!
>
> Here is the full err:
>
> Root-NFS: No NFS server available, giving up.
> VFS: Unable to mount root fs via NFS, trying floppy.
> VFS: Cannot open root device "sda2" or unknown-block(2,0)
> Please append a correct "root=" boot option
> Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
>
> Doing a bit of research on the error message, found the following threads on
> xen-devel:
> http://lists.xensource.com/archives/html/xen-devel/2004-10/msg00382.html
> http://lists.xensource.com/archives/html/xen-devel/2004-12/msg00470.html
>
> I'm thinking this might not be a xen problem, but a grub problem?
>
> Still working on the issue, any tips would be appreciated.
>
> Thanks.
>
> -Matthew
>
> _______________________________________________
> Xen-users mailing list
> [hidden email]
> http://lists.xensource.com/xen-users
>


--
-Yvette Chanco
www.option-c.com

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users