[Knowhow] Enable network of VTi domian(FYI)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Knowhow] Enable network of VTi domian(FYI)

Zhang, Xiantao
Hi all,
Currently, due to no implementation for VNIF driver in Xen0, So the
network of VTi domain can't work with the latest configuration. This is
a knowhow for enabling it with a legacy mode which directly connects
bridge rather than through vnif.

1. copy network-bridge(attachment)  /etc/xen/scripts/network-bridge
-->>overwrite the old one.

2. Enbale the NIC option in VTi's configuration file.
>>>>>>>>>>>>>>>>>>>>----------------<<<<<<<<<<<<<<<<<<<<<<<<<
# Optionally define mac and/or bridge for the network interfaces.
# Random MACs are assigned if not given.
#vif = [ 'type=ioemu, mac=00:16:3e:00:00:11, bridge=xenbr0' ]
# type=ioemu specify the NIC is an ioemu device not netfront
vif = [ 'type=ioemu, bridge=xenbr0' ]<<<<<<<<<<<<< Enable this line .
# for multiple NICs in device model, 3 in this example
#vif = [ 'type=ioemu, bridge=xenbr0', 'type=ioemu', 'type=ioemu']
>>>>>>>>>>>>>>>>>>------------------<<<<<<<<<<<<<<<<<<<<<<<<<
BTW, if you don't want to enable network of VTi domain, had better
disable this line in case that it may bring some side effect such as
wasting more time for probing network when starting VTi domain and so
on.

3. Xend start

4. Create VTi domain.
Thanks!
Zhang Xiantao
CSD-OTC PRC Virtualization
Intel (China) Limited


_______________________________________________
Xen-ia64-devel mailing list
[hidden email]
http://lists.xensource.com/xen-ia64-devel

network-bridge (6K) Download Attachment