Quantcast

LSI 9305-16i issue in Xen Dom0 Ubuntu

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

LSI 9305-16i issue in Xen Dom0 Ubuntu

Richard Lagler
Dear Community,



I have realised that an scsih issue timeout occurs with my
Broadcom/Avago/LSI 9305-16i (SAS3224) HDA controller in Dom0, Ubuntu
17.04. The same issue derives also in a DomU guest using virtual block
disks.

Detailed output:
mpt3sas_cm0:

mpt3sas_scsih_issue_tm:timeout

The issue occures when start working with the disks, e.g. open gparted,
copy files.



In a normal Ubuntu boot without Xen I can use the LSI HDA with 16 disks
without any issues.

With a blacklisted LSI mpt3sas in Dom0 and disks on internal SATA ports
no issues can be observed.

So I can conclude Xen and mpt3sas (LSI) derives the issue.


Is anyone using an LSI HDA with Xen and knows how to fix this issue?
Thank you in advance!


Kind Regards,
Richard

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LSI 9305-16i issue in Xen Dom0 Ubuntu

andy smith-10
Hi Richard,

On Wed, May 10, 2017 at 04:23:52PM +0200, Richard Lagler wrote:
> I have realised that an scsih issue timeout occurs with my
> Broadcom/Avago/LSI 9305-16i (SAS3224) HDA controller in Dom0, Ubuntu
> 17.04. The same issue derives also in a DomU guest using virtual
> block disks.
>
> Detailed output:
> mpt3sas_cm0:
>
> mpt3sas_scsih_issue_tm:timeout

I don't recall seeing that exact error but I did experience problems
with mpt3sas under Xen (but not bare metal) until I gave dom0 at
least 4GiB RAM:

    https://lists.xenproject.org/archives/html/xen-users/2017-01/msg00083.html

Cheers,
Andy

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Loading...