Rebooting fails with more than one (lvm) phy in config (amd64 debian testing/unstable)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Rebooting fails with more than one (lvm) phy in config (amd64 debian testing/unstable)

Robin van Leeuwen
Hi,

Setup: xen-unstable (last hg pull -u: 2005-08-20 21:51)
Dom0, debian 3.1 amd64 testing/unstable
DomU, debian 3.1 amd64 stable

I have a setup in which i have a rootfs for domU on lvm (/dev/xen/samba-ha)
and a datafs (which is going to be used in domU to store samba data on,
it's
currently empty , but a valid ext3 filesystem) on lvm (/dev/xen/samba-ha-fs)

I configured them in my /etc/xen/samba-ha:

    disk =
['phy:/dev/xen/samba-ha,hda1,w','phy:/dev/xen/samba-ha-fs,hda2,w']

In my fstab on my domU (samba-ha) i have:

    /dev/hda2       /fs             ext3   defaults         0       1

In my current setup i don't do anything with /dev/hda2, i don't mount
it, i don't use it.

When i reboot this domU (samba-ha) it does not reboot. It stops at
"Rebooting System"
and returns to the dom0 prompt.

See bottom of mail for xend.log.

I isolated the problem to the adding of the phy:/dev/xen/samba-ha-fs as
hda2.
If i don't use that LVM disk as hda2 it reboots fine.

What am i doing wrong? Or is this a bug?

------------  /var/log/xend.log -------------------
[2005-08-21 01:50:16 xend] DEBUG (XendDomain:214) XendDomain>reap>
domain died name=samba-ha id=10
[2005-08-21 01:50:16 xend] DEBUG (XendDomain:217) XendDomain>reap>
shutdown name=samba-ha id=10 reason=reboot
[2005-08-21 01:50:16 xend] INFO (XendRoot:141) EVENT> xend.domain.exit
['samba-ha', 10, 'reboot']
[2005-08-21 01:50:16 xend] DEBUG (XendDomain:464)
domain_restart_schedule> 10 reboot 0
[2005-08-21 01:50:16 xend] INFO (XendDomain:471) Scheduling restart for
domain: name=samba-ha id=10
[2005-08-21 01:50:16 xend] INFO (XendRoot:141) EVENT>
xend.domain.restart ['samba-ha', 10, 'schedule']
[2005-08-21 01:50:16 xend] INFO (XendDomain:506) Destroying domain:
name=samba-ha
[2005-08-21 01:50:16 xend] INFO (XendRoot:141) EVENT>
xend.domain.destroy ['samba-ha', 10]
[2005-08-21 01:50:16 xend] DEBUG (netif:502) Destroying netif domain=10
[2005-08-21 01:50:16 xend] DEBUG (netif:395) Destroying vif domain=10 vif=0
[2005-08-21 01:50:16 xend] INFO (process:35) [vif-bridge] vif-bridge
down vif=vif10.0 domain=samba-ha mac=aa:00:00:52:6f:40 bridge=xen-br0
[2005-08-21 01:50:16 xend] DEBUG (blkif:474) Destroying blkif domain=10
[2005-08-21 01:50:16 xend] DEBUG (blkif:362) Destroying vbd domain=10 id=0
[2005-08-21 01:50:16 xend] DEBUG (blkif:278) Unbinding vbd (type phy)
from /dev/xen/samba-ha
[2005-08-21 01:50:16 xend] DEBUG (blkif:362) Destroying vbd domain=10 id=1
[2005-08-21 01:50:16 xend] DEBUG (blkif:278) Unbinding vbd (type phy)
from /dev/xen/samba-ha-fs
[2005-08-21 01:50:17 xend] INFO (xsobj:337) DBMap>releaseDomain> 10
[2005-08-21 01:50:17 xend] INFO (XendDomain:300) Restarting domain:
name=samba-ha id=10
[2005-08-21 01:50:17 xend] INFO (XendDomain:300) Restarting domain:
name=samba-ha id=10
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT>
xend.domain.restart ['samba-ha', 10, 'begin']
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT>
xend.domain.restart ['samba-ha', 10, 'begin']
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT> xend.virq 3
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT> xend.virq 3
[2005-08-21 01:50:17 xend] DEBUG (image:153) initDomain: cpu=-1
mem_kb=524288 ssidref=-1 dom=10
[2005-08-21 01:50:17 xend] DEBUG (XendDomainInfo:696) init_domain>
Created domain=10 name=samba-ha memory=512
[2005-08-21 01:50:17 xend] INFO (image:208) buildDomain os=linux dom=10
vcpus=1
[2005-08-21 01:50:17 xend] ERROR (XendDomainInfo:858) VM samba-ha
restarting too fast
[2005-08-21 01:50:17 xend] ERROR (XendDomain:311) Exception restarting
domain: name=samba-ha id=10
Traceback (most recent call last):
  File "/usr/lib/python/xen/xend/XendDomain.py", line 304, in domain_restart
    dominfo.restart()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 871, in restart
    self.restart_check()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 859, in
restart_check
    raise VmError(msg)
VmError: VM samba-ha restarting too fast
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT>
xend.domain.restart ['samba-ha', 10, 'fail']
[2005-08-21 01:50:17 xend] INFO (xsobj:326) DBMap>introduceDomain> 10
383898 <EventChannel dom1:0:17 dom2:10:2>
/domain/731534ab-a92b-4921-8a42-f89aec4676f1
[2005-08-21 01:50:17 xend] DEBUG (XendDomainInfo:571) writing key
availability=online to path /cpu/0 in store
[2005-08-21 01:50:17 xend] WARNING (XendDomainInfo:947) Unknown config
field boot
[2005-08-21 01:50:17 xend] WARNING (XendDomainInfo:947) Unknown config
field display
[2005-08-21 01:50:17 xend] INFO (xsobj:337) DBMap>releaseDomain> 10
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT> xend.virq 3
[2005-08-21 01:50:17 xend] ERROR (XendDomain:311) Exception restarting
domain: name=samba-ha id=10
Traceback (most recent call last):
  File "/usr/lib/python/xen/xend/XendDomain.py", line 304, in domain_restart
    dominfo.restart()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 876, in restart
    self.construct(self.config)
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 529, in construct
    self.configure()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 920, in configure
    self.create_devices()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 749, in
create_devices
    self.create_configured_devices()
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 738, in
create_configured_devices
    self.createDevice(ctrl_type, dev_config)
  File "/usr/lib/python/xen/xend/XendDomainInfo.py", line 385, in
createDevice
    change=change)
  File "/usr/lib/python/xen/xend/server/controller.py", line 283, in
createDevice
    dev.attach(recreate=recreate, change=change)
  File "/usr/lib/python/xen/xend/server/blkif.py", line 271, in attach
    self.setNode(node)
  File "/usr/lib/python/xen/xend/server/blkif.py", line 300, in setNode
    raise VmError("vbd: Segment %s is in writable use" %
VmError: vbd: Segment phy:/dev/xen/samba-ha is in writable use
[2005-08-21 01:50:17 xend] INFO (XendRoot:141) EVENT>
xend.domain.restart ['samba-ha', 10, 'fail']
-------------------------------------------------------------------------------------------


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel