Unable to boot on Xen Hypervisor EFI

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to boot on Xen Hypervisor EFI

Berillions
Hi,

i installed yesterday a fresh Debian Sid on my new desktop :
Processor : AMD Ryzen 1700X
MB : Asus X370 PRIME
GPU : Amd rx560

I have the kernel 4.11 and i installed Xen 4.8 from the repository. My Debian is installed with the UEFI mod so all my partitions are GPT.

For the first time when i boot on Xen EFI, i had this message :
Loading Xen 4.8-amd64.efi ...
error: invalid arch-dependent ELF magic.
Loading Linux 4.11.0-1-amd64 ...
error: you need to load the kernel first.
Loading initial ramdisk ...
error: you need to load the kernel first.

I follow the how-to here : http://wiki.xenproject.org/wiki/Xen_EFI 

when i launch the efibootmgr command for Xen, i have this :  
root@debian-desktop:# efibootmgr -w -L Xen -l "\EFI\Xen\xen-4.8-amd64.efi" -c
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0002,0000,0001
Boot0000* debian
Boot0001* Hard Drive
Boot0002* Xen

Unfortunatly, when i choose Xen hypervisor EFI in the grub, i still have the previous error. If i choose Xen 'normal' (no-EFI), the system hangs.

Thanks for your help,
Maxime
 

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to boot on Xen Hypervisor EFI

John L. Poole
This may help:
https://forums.gentoo.org/viewtopic-p-7992830.html?sid=513bdbbc364e06945d62e46367119426

On Thu, Jul 13, 2017 at 8:55 AM, Berillions <[hidden email]> wrote:

> Hi,
>
> i installed yesterday a fresh Debian Sid on my new desktop :
>>
>> Processor : AMD Ryzen 1700X
>> MB : Asus X370 PRIME
>> GPU : Amd rx560
>
>
> I have the kernel 4.11 and i installed Xen 4.8 from the repository. My
> Debian is installed with the UEFI mod so all my partitions are GPT.
>
> For the first time when i boot on Xen EFI, i had this message :
>>
>> Loading Xen 4.8-amd64.efi ...
>> error: invalid arch-dependent ELF magic.
>> Loading Linux 4.11.0-1-amd64 ...
>> error: you need to load the kernel first.
>> Loading initial ramdisk ...
>> error: you need to load the kernel first.
>
>
> I follow the how-to here : http://wiki.xenproject.org/wiki/Xen_EFI
>
> when i launch the efibootmgr command for Xen, i have this :
>>
>> root@debian-desktop:# efibootmgr -w -L Xen -l "\EFI\Xen\xen-4.8-amd64.efi"
>> -c
>> BootCurrent: 0000
>> Timeout: 1 seconds
>> BootOrder: 0002,0000,0001
>> Boot0000* debian
>> Boot0001* Hard Drive
>> Boot0002* Xen
>
>
> Unfortunatly, when i choose Xen hypervisor EFI in the grub, i still have the
> previous error. If i choose Xen 'normal' (no-EFI), the system hangs.
>
> Thanks for your help,
> Maxime
>
>
> _______________________________________________
> Xen-users mailing list
> [hidden email]
> https://lists.xen.org/xen-users



--
John L. Poole

1566 Court St NE
Salem  OR  97301-4241
707-812-1323

[hidden email]

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to boot on Xen Hypervisor EFI

Berillions
Does not work for me. Even if i download Shell.efi file and put it in my FAT32 USB Key, i don't have access into the UEFI Shell ...
I also tried to put the file into "/boot/efi/" but no success to :-(

2017-07-14 15:50 GMT+02:00 John Laurence Poole <[hidden email]>:
This may help:
https://forums.gentoo.org/viewtopic-p-7992830.html?sid=513bdbbc364e06945d62e46367119426

On Thu, Jul 13, 2017 at 8:55 AM, Berillions <[hidden email]> wrote:
> Hi,
>
> i installed yesterday a fresh Debian Sid on my new desktop :
>>
>> Processor : AMD Ryzen 1700X
>> MB : Asus X370 PRIME
>> GPU : Amd rx560
>
>
> I have the kernel 4.11 and i installed Xen 4.8 from the repository. My
> Debian is installed with the UEFI mod so all my partitions are GPT.
>
> For the first time when i boot on Xen EFI, i had this message :
>>
>> Loading Xen 4.8-amd64.efi ...
>> error: invalid arch-dependent ELF magic.
>> Loading Linux 4.11.0-1-amd64 ...
>> error: you need to load the kernel first.
>> Loading initial ramdisk ...
>> error: you need to load the kernel first.
>
>
> I follow the how-to here : http://wiki.xenproject.org/wiki/Xen_EFI
>
> when i launch the efibootmgr command for Xen, i have this :
>>
>> root@debian-desktop:# efibootmgr -w -L Xen -l "\EFI\Xen\xen-4.8-amd64.efi"
>> -c
>> BootCurrent: 0000
>> Timeout: 1 seconds
>> BootOrder: 0002,0000,0001
>> Boot0000* debian
>> Boot0001* Hard Drive
>> Boot0002* Xen
>
>
> Unfortunatly, when i choose Xen hypervisor EFI in the grub, i still have the
> previous error. If i choose Xen 'normal' (no-EFI), the system hangs.
>
> Thanks for your help,
> Maxime
>
>
> _______________________________________________
> Xen-users mailing list
> [hidden email]
> https://lists.xen.org/xen-users



--
John L. Poole

1566 Court St NE
Salem  OR  97301-4241
<a href="tel:707-812-1323" value="+17078121323">707-812-1323

[hidden email]


_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Loading...