Upstream Qemu With Xen configuration problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upstream Qemu With Xen configuration problem

Daniel Castro
Greetings,

I am trying to configure Xen4.2 unstable with upstream qemu. I am
running on a small problem when running the configuration of qemu,
Qemu Config can not find Xen. I have debugged the Configuration script
and the temp c file that qemu uses to detect xen version are returning
empty string, hence the config script can tell xen version. Xen with
staging branch works fine.
My configure call is as follows:
./configure --enable-xen --target-list=i386-softmmu
--extra-cflags="-I/usr/src/xen-unstable.hg/dist/install/usr/include"
--extra-ldflags="-L/usr/src/xen-unstable.hg/dist/install/usr/lib"
--enable-debug

The contents of /usr/src/xen-unstable.hg/dist/install/usr/include are:
blktaplib.h       libxl.h         temp.c          xenguest.h    xs_lib.h
fsimage_grub.h    _libxl_types.h  xen             xenstat.h
fsimage.h         libxl_utils.h   xenctrl.h       xentoollog.h
fsimage_plugin.h  libxl_uuid.h    xenctrlosdep.h  xs.h

The contents of /usr/src/xen-unstable.hg/dist/install/usr/lib are:
python2.7  xen

Qemu is on master branch 744d3644181ddb16ef5944a0f9217e46961c8c84
"pxa2xx_lcd: add proper rotation support"
Xen is on unstable branch 23608:2f63562df1c4 "libxl: Do not SEGV when
no 'removable' disk parameter in xenstore"

I can change xen changeset freely, but I can not change qemu changeset
since I need some features present in qemu.

Any help, or pointers are greatly appreciated.

Thanks for your time,

Daniel





--
+-=====---------------------------+
| +---------------------------------+ | This space intentionally blank
for notetaking.
| |   | Daniel Castro,                |
| |   | Consultant/Programmer.|
| |   | U Andes                         |
+-------------------------------------+

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: Upstream Qemu With Xen configuration problem

Daniel Castro
> Date: Thu, 07 Jul 2011 14:29:43 -0400
> From: John Baboval <[hidden email]>
> To: [hidden email]
> Subject: Re: [Qemu-devel] Upstream Qemu With Xen configuration problem
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> I find I have to point at the src directories, and not the dist
> directory. My extra-cflags looks something like this:
>
> --extra-cflags=-I /path/to/xen/tools/include -L /path/to/xen/tools/libxc
> -I /path/to/xen/tools/libxc -L /path/to/xen/tools/xenstore -I
> /path/to/xen/tools/xenstore'

Thanks John, that helped, I also found out that somehow I am missing
the file xc_e820.h from /usr/include I had to manually copy it to that
location and all is working now.



> -John


> On 07/07/2011 01:17 PM, Daniel Castro wrote:
> > Greetings,
> >
> > I am trying to configure Xen4.2 unstable with upstream qemu. I am
> > running on a small problem when running the configuration of qemu,
> > Qemu Config can not find Xen. I have debugged the Configuration script
> > and the temp c file that qemu uses to detect xen version are returning
> > empty string, hence the config script can tell xen version. Xen with
> > staging branch works fine.
> > My configure call is as follows:
> > ./configure --enable-xen --target-list=i386-softmmu
> > --extra-cflags="-I/usr/src/xen-unstable.hg/dist/install/usr/include"
> > --extra-ldflags="-L/usr/src/xen-unstable.hg/dist/install/usr/lib"
> > --enable-debug
> >
> > The contents of /usr/src/xen-unstable.hg/dist/install/usr/include are:
> > blktaplib.h       libxl.h         temp.c          xenguest.h    xs_lib.h
> > fsimage_grub.h    _libxl_types.h  xen             xenstat.h
> > fsimage.h         libxl_utils.h   xenctrl.h       xentoollog.h
> > fsimage_plugin.h  libxl_uuid.h    xenctrlosdep.h  xs.h
> >
> > The contents of /usr/src/xen-unstable.hg/dist/install/usr/lib are:
> > python2.7  xen
> >
> > Qemu is on master branch 744d3644181ddb16ef5944a0f9217e46961c8c84
> > "pxa2xx_lcd: add proper rotation support"
> > Xen is on unstable branch 23608:2f63562df1c4 "libxl: Do not SEGV when
> > no 'removable' disk parameter in xenstore"
> >
> > I can change xen changeset freely, but I can not change qemu changeset
> > since I need some features present in qemu.
> >
> > Any help, or pointers are greatly appreciated.
> >
> > Thanks for your time,
> >
> > Daniel
> >
> >
> >
> >
> >

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel