Quantcast

Xen-tools/utils Version Confusion

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Xen-tools/utils Version Confusion

ray-2

I would like to get xen-tools working on Debian 9 stretch, with Xen 4.8.1.


When I enter

xl

I get the message

ERROR:  Can't find version 4.6 of xen utils, bailing out.


I attempted

apt-get install xen-tools

but received the message

xen-utils-4.8 is already the newest version (4.8.1-1+deb9u1)


How do I get xl to work?


Ray 
   


_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xen-tools/utils Version Confusion

George Dunlap-5
On Thu, May 18, 2017 at 3:23 PM, Ray Joseph <[hidden email]> wrote:
> I would like to get xen-tools working on Debian 9 stretch, with Xen 4.8.1.

Sorry, do you mean the Xen user-land tools (like xl, xentop, qemu-dm,
and so on), or do you mean xen-tools, the confusingly-named package
designed to make it easy to generate Xen guest images and
corresponding config scripts[1]?

[1] https://xen-tools.org/software/xen-tools/

> When I enter
>
> xl
>
> I get the message
>
> ERROR:  Can't find version 4.6 of xen utils, bailing out.
>
>
> I attempted
>
> apt-get install xen-tools
>
> but received the message
>
> xen-utils-4.8 is already the newest version (4.8.1-1+deb9u1)

The Xen userspace tools are linked to the running Xen hypervisor
version.  It looks like you may have Xen hypervisor 4.6, but not have
the Xen 4.6 tools, but only the Xen 4.8 tools.

> How do I get xl to work?

My guess would be either reboot into Xen 4.8, or install xen-utils-4.6.

CC'ing Ian Jackson, who has been doing work on the Debian Xen package,
in case I've said something wrong and/or you need further help.

 -George

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xen-tools/utils Version Confusion

Ian Jackson-2
George Dunlap writes ("Re: [Xen-users] Xen-tools/utils Version Confusion"):
> On Thu, May 18, 2017 at 3:23 PM, Ray Joseph <[hidden email]> wrote:
> > I would like to get xen-tools working on Debian 9 stretch, with Xen 4.8.1.
...
> > When I enter
> >
> > xl
> >
> > I get the message
> >
> > ERROR:  Can't find version 4.6 of xen utils, bailing out.

I think George's suggestion of mismatched versions is plausible.

Also, maybe you need to reboot ?  If you upgraded your stretch install
but have not yet rebooted, you might still be running a 4.6 hypervisor
and have no 4.6 tools.

> > How do I get xl to work?
>
> My guess would be either reboot into Xen 4.8, or install xen-utils-4.6.

Yes.

Ianb.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xen-tools/utils Version Confusion

ray-2
In reply to this post by George Dunlap-5

--------- Original Message ---------

> Subject: Re: [Xen-users] Xen-tools/utils Version Confusion
> From: "George Dunlap" <
[hidden email]>
> Date: 5/18/17 11:11 am
> To: "Ray Joseph" <
[hidden email]>
> Cc: "
[hidden email]" <[hidden email]>, "Ian Jackson" <[hidden email]>

>On Thu, May 18, 2017 at 3:23 PM, Ray Joseph <
[hidden email]> wrote:
>> I would like to get xen-tools working on Debian 9 stretch, with Xen 4.8.1.

> Sorry, do you mean the Xen user-land tools (like xl, xentop, qemu-dm,
> and so on), or do you mean xen-tools, the confusingly-named package
> designed to make it easy to generate Xen guest images and
> corresponding config scripts[1]?

Yes, I meant xen-tools in userland.


> [1]
https://xen-tools.org/software/xen-tools/


> >When I enter
>>
>> xl
>>
>> I get the message
>>
>> ERROR: Can't find version 4.6 of xen utils, bailing out.
>>
>>
>> I attempted
>>
>> apt-get install xen-tools

 

What I actually input was xen-utils, not xen-tools (at this point)


>>
>> but received the message
>>
>> xen-utils-4.8 is already the newest version (4.8.1-1+deb9u1)


> The Xen userspace tools are linked to the running Xen hypervisor
> version. It looks like you may have Xen hypervisor 4.6, but not have
> the Xen 4.6 tools, but only the Xen 4.8 tools.

 

By being linked, do you mean xen-tools 4.8 should be installed if Xen 4.8 is installed?

I rechecked, and I am running Xen 4.8.1. I would expect xen-tools 4.8 to be installed and require the latest xen-utils (4.8).

When I run

apt-get xen-tools

the system reports

xen-tools is already the latest version (4.7-1)

>> How do I get xl to work?

> My guess would be either reboot into Xen 4.8, or install xen-utils-4.6.

 

If I install xen-utils-4.6, it would seem it would then be out of since with Xen 4.8.

It looks like the culprit is xen-tools 4.7. It seems out of sync with xen-utils and Xen.

I just checked and xen-tools 4.7 is the latest.

 

I will reboot and and try this again.

[Note: I just read Ian’s comments – reboot.}



> CC'ing Ian Jackson, who has been doing work on the Debian Xen package,
> in case I've said something wrong and/or you need further help.

> -George

Ray

BTW, I need to learn how and what email client to use for this


_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xen-tools/utils Version Confusion, Solved

ray-2
In reply to this post by Ian Jackson-2
Thank you all.
 
Rebooting saved the day. 
 
Ray
 
 
--------- Original Message ---------
Subject: Re: [Xen-users] Xen-tools/utils Version Confusion
From: "Ian Jackson" <[hidden email]>
Date: 5/18/17 12:42 pm
To: "George Dunlap" <[hidden email]>
Cc: "Ray Joseph" <[hidden email]>, "[hidden email]" <[hidden email]>

George Dunlap writes ("Re: [Xen-users] Xen-tools/utils Version Confusion"):
> On Thu, May 18, 2017 at 3:23 PM, Ray Joseph <[hidden email]> wrote:
> > I would like to get xen-tools working on Debian 9 stretch, with Xen 4.8.1.
...
> > When I enter
> >
> > xl
> >
> > I get the message
> >
> > ERROR: Can't find version 4.6 of xen utils, bailing out.

I think George's suggestion of mismatched versions is plausible.

Also, maybe you need to reboot ? If you upgraded your stretch install
but have not yet rebooted, you might still be running a 4.6 hypervisor
and have no 4.6 tools.

> > How do I get xl to work?
>
> My guess would be either reboot into Xen 4.8, or install xen-utils-4.6.

Yes.

Ianb.

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xen.org/xen-users
Loading...