can't find arch/xen/xen-public/io/console.h building xencons_ring.c in 29db5bded574

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

can't find arch/xen/xen-public/io/console.h building xencons_ring.c in 29db5bded574

Charles Duffy-6
   CC      drivers/xen/console/xencons_ring.o
drivers/xen/console/xencons_ring.c:23:43:
asm-xen/xen-public/io/console.h: No such file or directory
drivers/xen/console/xencons_ring.c: In function `xencons_ring_send':
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: warning: implicit declaration of
function `MASK_XENCONS_IDX'
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:42: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c: In function `handle_input':
drivers/xen/console/xencons_ring.c:56: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:56: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:59: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:59: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:60: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:62: error: dereferencing pointer to
incomplete type
make[6]: *** [drivers/xen/console/xencons_ring.o] Error 1
make[5]: *** [drivers/xen/console] Error 2
make[4]: *** [drivers/xen] Error 2
make[3]: *** [drivers] Error 2
make[3]: Leaving directory `/usr/src/xen-unstable.hg/linux-2.6.12-xen0'


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

oops -- strike that

Charles Duffy-6
My fault; wasn't building from a completely clean tree. Apologies for
the trouble.


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: can't find arch/xen/xen-public/io/console.h building xencons_ring.c in 29db5bded574

Rami Rosen-2
In reply to this post by Charles Duffy-6
Hello,

 Yes, I have this too;  something went wrong probably lately.

As a workaround ,until it will be fixed (hopefully soon), I did added a symbolic link named console.h to
xen/include/public/io/console.h
in
linux-2.6.12-xen0/include/asm-xen/xen-public/io
and also in
linux-2.6.12-xenU/include/asm-xen/xen-public/io
and ran make again; this time the
build was completed succesfully with no further errors.

Regards,
Rami Rosen




On 10/13/05, Charles Duffy <[hidden email]> wrote:
   CC      drivers/xen/console/xencons_ring.o
drivers/xen/console/xencons_ring.c:23:43:
asm-xen/xen-public/io/console.h: No such file or directory
drivers/xen/console/xencons_ring.c: In function `xencons_ring_send':
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:39: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: warning: implicit declaration of
function `MASK_XENCONS_IDX'
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:40: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:42: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c: In function `handle_input':
drivers/xen/console/xencons_ring.c:56: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:56: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:59: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:59: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:60: error: dereferencing pointer to
incomplete type
drivers/xen/console/xencons_ring.c:62: error: dereferencing pointer to
incomplete type
make[6]: *** [drivers/xen/console/xencons_ring.o] Error 1
make[5]: *** [drivers/xen/console] Error 2
make[4]: *** [drivers/xen] Error 2
make[3]: *** [drivers] Error 2
make[3]: Leaving directory `/usr/src/xen-unstable.hg/linux-2.6.12-xen0'


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: can't find arch/xen/xen-public/io/console.h building xencons_ring.c in 29db5bded574

Charles Duffy-6
Rami Rosen wrote:
>  Yes, I have this too;  something went wrong probably lately.

Actually, just clearing out my kernel trees and rebuilding from scratch
resolved the issue.

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: can't find arch/xen/xen-public/io/console.h building xencons_ring.c in 29db5bded574

Rami Rosen-2
Hello,
   Well, in fact I did not clean my tree, which is the right way, after performing a pool , and I thought something went wrong , so I tried
that workaround (which worked) . Needles to say,  a full rebuild is the proper and correct way.

Regards,
Rami


On 10/13/05, Charles Duffy <[hidden email]> wrote:
Rami Rosen wrote:
>  Yes, I have this too;  something went wrong probably lately.

Actually, just clearing out my kernel trees and rebuilding from scratch
resolved the issue.


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel