dm_mod: no version for "struct_module" found: kernel tainted

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

dm_mod: no version for "struct_module" found: kernel tainted

Shaun Reitan
I used the xensource install script for RHEL4 and after trying to boot on
the new kernel the system just continually rebooted.  I appended a noreboot
to the xen line and now i'm seeing the following...

Freeing unused kernel memory: 184k freed
dm_mod: no version for "struct_module" found: kernel tainted.
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: [hidden email]
kernel panic - not syncing: attempted to kill init!

Anybody have a idea whats going on here?

~Shaun




_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users
Reply | Threaded
Open this post in threaded view
|

Re: dm_mod: no version for "struct_module" found: kernel tainted

Eric Peterson-2
Shaun,

If it helps, I used the install scripts with FC4, but had many problems with them.

I have since rebuilt the machine and have compiled Xen from the testing source.  Everything seems to be working well.

As an example, with the install scripts the networking was broken for my domU installs and I had to fix the problem in the networking scripts to get it to work.  After building from the source, everything worked great from the beginning. 

Another problem I had was that the networking on the domU installs would go down during high network loads.  I have not seen the same problem, so far, with the compiled version I'm using now.

-Eric

On 1/12/06, Shaun Reitan <[hidden email]> wrote:
I used the xensource install script for RHEL4 and after trying to boot on
the new kernel the system just continually rebooted.  I appended a noreboot
to the xen line and now i'm seeing the following...

Freeing unused kernel memory: 184k freed
dm_mod: no version for "struct_module" found: kernel tainted.
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: [hidden email]
kernel panic - not syncing: attempted to kill init!

Anybody have a idea whats going on here?

~Shaun




_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users


_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users