Quantcast

gplpv installer fails to detect testsigning on win7 ultimate x64

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gplpv installer fails to detect testsigning on win7 ultimate x64

Florian Manschwetus
I tried to test the gplpv driver on my Win7 guest on top of my b130 osol
xvm. I enabled testsigining with "Bcdedit.exe -set TESTSIGNING ON"
And rebooted according to bcdedit testsigning is enabled
(http://msdn.microsoft.com/en-us/library/dd419910.aspx), but the
installer refuses to install, requesting testsigning to be enabled.

Regards,
florian


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gplpv installer fails to detect testsigning on win7 ultimate x64

Pasi Kärkkäinen
On Tue, Jan 12, 2010 at 10:40:08AM +0100, Florian Manschwetus wrote:
> I tried to test the gplpv driver on my Win7 guest on top of my b130 osol
> xvm. I enabled testsigining with "Bcdedit.exe -set TESTSIGNING ON"
> And rebooted according to bcdedit testsigning is enabled
> (http://msdn.microsoft.com/en-us/library/dd419910.aspx), but the
> installer refuses to install, requesting testsigning to be enabled.
>

What version of gplpv did you try?

Looking at the changelog:
http://xenbits.xen.org/ext/win-pvdrivers.hg

It seems version 0.11.0.202 and newer have this:
"Detect if testsigning is on on Vista and above (x64 only)"

-- Pasi


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gplpv installer fails to detect testsigning on win7 ultimate x64

Florian Manschwetus
Am 12.01.2010 10:47, schrieb Pasi Kärkkäinen:

> On Tue, Jan 12, 2010 at 10:40:08AM +0100, Florian Manschwetus wrote:
>> I tried to test the gplpv driver on my Win7 guest on top of my b130 osol
>> xvm. I enabled testsigining with "Bcdedit.exe -set TESTSIGNING ON"
>> And rebooted according to bcdedit testsigning is enabled
>> (http://msdn.microsoft.com/en-us/library/dd419910.aspx), but the
>> installer refuses to install, requesting testsigning to be enabled.
>>
>
> What version of gplpv did you try?
>
> Looking at the changelog:
> http://xenbits.xen.org/ext/win-pvdrivers.hg
>
> It seems version 0.11.0.202 and newer have this:
> "Detect if testsigning is on on Vista and above (x64 only)"
>
> -- Pasi
>
Is there already an installer for this version available?
on http://www.meadowcourt.org/downloads/ it is not?

florian


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: gplpv installer fails to detect testsigning on win7 ultimate x64

James Harper
In reply to this post by Florian Manschwetus
>
> I tried to test the gplpv driver on my Win7 guest on top of my b130 osol
> xvm. I enabled testsigining with "Bcdedit.exe -set TESTSIGNING ON"
> And rebooted according to bcdedit testsigning is enabled
> (http://msdn.microsoft.com/en-us/library/dd419910.aspx), but the
> installer refuses to install, requesting testsigning to be enabled.
>

What is in the HKLM\SYSTEM\CurrentControlSet\Control SystemStartOptions
registry value? I check for '/TESTSIGNING', maybe Windows 7 has changed how
that works.

Thanks

James

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: RE: gplpv installer fails to detect testsigning on win7 ultimate x64

Pasi Kärkkäinen
On Tue, Jan 12, 2010 at 09:58:07PM +1100, James Harper wrote:

> >
> > I tried to test the gplpv driver on my Win7 guest on top of my b130 osol
> > xvm. I enabled testsigining with "Bcdedit.exe -set TESTSIGNING ON"
> > And rebooted according to bcdedit testsigning is enabled
> > (http://msdn.microsoft.com/en-us/library/dd419910.aspx), but the
> > installer refuses to install, requesting testsigning to be enabled.
> >
>
> What is in the HKLM\SYSTEM\CurrentControlSet\Control SystemStartOptions
> registry value? I check for '/TESTSIGNING', maybe Windows 7 has changed how
> that works.
>

Florian: Did you check what the registry value was?

-- Pasi


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Loading...