libvirtd + xl hang on CentOS6

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

libvirtd + xl hang on CentOS6

Martin Zichacek

Hi,

We are experiencing libvirtd hangs after last May centos6-xen update on multiple instances.

Disconnected from xen:/// due to keepalive timeout

xen-4.6.6-12.el6.x86_64

Remedy is to kill -9 libvirtd and start again. Issue can be replicated
within few domU starts. Usually libvirtd hangs when domU is bringing up
xen drivers or something around udev, like:

xen_netfront: Initialising Xen virtual ethernet driver

I've been looking into libvirtd strace and debug logs, so far most
suspicious in libvirtd debug log is this:

libvirtd.log:2018-05-22 08:32:44.760+0000: 25455: debug :
udevRemoveOneDevice:1289 : Failed to find device to remove that has udev
name '/sys/devices/vif-24-0/net/vif24.0/queues/tx-7'
libvirtd.log:2018-05-22 08:32:44.761+0000: 25455: debug :
udevRemoveOneDevice:1289 : Failed to find device to remove that has udev
name '/sys/devices/vif-24-0/net/vif24.0/queues/tx-6'
libvirtd.log:2018-05-22 08:32:44.761+0000: 25455: debug :

Is someone out there seeing similar issues? Anyone perhaps interested in
reviewing full debug log / strace ?


Original post from lists.centos.org:

https://lists.centos.org/pipermail/centos-virt/2018-May/005809.html

_______________________________________________
Xen-users mailing list
[hidden email]
https://lists.xenproject.org/mailman/listinfo/xen-users