tpm_vtpm: tpm_transmit: tpm_send: error 4294967294

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

tpm_vtpm: tpm_transmit: tpm_send: error 4294967294

Martin Hermanowski-5
Hello,

I downloaded xen-testing yesterday evening, and there is a strange problem:

I start the vtpm_managerd, and when I load the tpm_xen module inside my
DomU, I can see that the vTPM gets initialized:

Initializing tpm: clear
...
TPMD[1]: tpm/tpm_startup.c:44: Info: TPM_Startup(1)

The vtpm_managerd also reacts on unloading the modules:
INFO[VTPM]: [1]: RECV[14}: 0x0 0 0 0 1 c1 0 0 0 e 0 0 0 2 0 0 0 1
INFO[VTPM]: Closing DMI 1.
INFO[TCS]: Calling TCS_CloseContext.
INFO[VTPM]: Killing dmi on pid 9446.
INFO[VTPM]: [1]: SENT: 0x0 0 0 0 1 c1 0 0 0 a 0 0 0 0

So I would assume that the communication channel between the DomU and
vtpm_managerd is fine.

But when I try to access the vTPM (directly or using /sys), I get an
error message:

tpm:~# cat /sys/devices/platform/tpm_vtpm/pcrs
 tpm_vtpm: tpm_transmit: tpm_send: error 4294967294

This is the same error message I get when the vtpm_managerd is not
running, also the vtpm_managerd does not display anything at this moment
(using strace it looks like it doesn't receive anything).

The strange part is, that I was able to use the vTPM once, but I am not
able to reproduce this...

Thanks,
Martin

--
Martin Hermanowski
http://martin.hermanowski.name


_______________________________________________
Xense-devel mailing list
[hidden email]
http://lists.xensource.com/xense-devel
Reply | Threaded
Open this post in threaded view
|

Re: tpm_vtpm: tpm_transmit: tpm_send: error 4294967294

Stefan Berger

[hidden email] wrote on 06/30/2006 05:40:05 AM:

> Hello,
>
> I downloaded xen-testing yesterday evening, and there is a strange problem:
>
> I start the vtpm_managerd, and when I load the tpm_xen module inside my
> DomU, I can see that the vTPM gets initialized:
>
> Initializing tpm: clear
> ...
> TPMD[1]: tpm/tpm_startup.c:44: Info: TPM_Startup(1)
>
> The vtpm_managerd also reacts on unloading the modules:
> INFO[VTPM]: [1]: RECV[14}: 0x0 0 0 0 1 c1 0 0 0 e 0 0 0 2 0 0 0 1
> INFO[VTPM]: Closing DMI 1.
> INFO[TCS]: Calling TCS_CloseContext.
> INFO[VTPM]: Killing dmi on pid 9446.
> INFO[VTPM]: [1]: SENT: 0x0 0 0 0 1 c1 0 0 0 a 0 0 0 0
>
> So I would assume that the communication channel between the DomU and
> vtpm_managerd is fine.
>
> But when I try to access the vTPM (directly or using /sys), I get an
> error message:
>
> tpm:~# cat /sys/devices/platform/tpm_vtpm/pcrs
>  tpm_vtpm: tpm_transmit: tpm_send: error 4294967294
>
> This is the same error message I get when the vtpm_managerd is not
> running, also the vtpm_managerd does not display anything at this moment
> (using strace it looks like it doesn't receive anything).
>
> The strange part is, that I was able to use the vTPM once, but I am not
> able to reproduce this...


I you can, please switch over to xen-unstable, though there you will also currently have to wait until several patches are going into the repository.

-- Stefan

_______________________________________________
Xense-devel mailing list
[hidden email]
http://lists.xensource.com/xense-devel
Reply | Threaded
Open this post in threaded view
|

Re: tpm_vtpm: tpm_transmit: tpm_send: error 4294967294

Martin Hermanowski-5
Stefan Berger wrote:

>
> [hidden email] wrote on 06/30/2006 05:40:05 AM:
>
>> Hello,
>>
>> I downloaded xen-testing yesterday evening, and there is a strange
> problem:
>>
>> I start the vtpm_managerd, and when I load the tpm_xen module inside my
>> DomU, I can see that the vTPM gets initialized:
>>
>> Initializing tpm: clear
>> ...
>> TPMD[1]: tpm/tpm_startup.c:44: Info: TPM_Startup(1)
>>
>> The vtpm_managerd also reacts on unloading the modules:
>> INFO[VTPM]: [1]: RECV[14}: 0x0 0 0 0 1 c1 0 0 0 e 0 0 0 2 0 0 0 1
>> INFO[VTPM]: Closing DMI 1.
>> INFO[TCS]: Calling TCS_CloseContext.
>> INFO[VTPM]: Killing dmi on pid 9446.
>> INFO[VTPM]: [1]: SENT: 0x0 0 0 0 1 c1 0 0 0 a 0 0 0 0
>>
>> So I would assume that the communication channel between the DomU and
>> vtpm_managerd is fine.
>>
>> But when I try to access the vTPM (directly or using /sys), I get an
>> error message:
>>
>> tpm:~# cat /sys/devices/platform/tpm_vtpm/pcrs
>>  tpm_vtpm: tpm_transmit: tpm_send: error 4294967294
>>
>> This is the same error message I get when the vtpm_managerd is not
>> running, also the vtpm_managerd does not display anything at this moment
>> (using strace it looks like it doesn't receive anything).
>>
>> The strange part is, that I was able to use the vTPM once, but I am not
>> able to reproduce this...
>
> I you can, please switch over to xen-unstable, though there you will
> also currently have to wait until several patches are going into the
> repository.

I nearly was waiting for this answer *g*.

Is -unstable stable enough to be run on a workstation? I can live with
random lock ups if they don't happen to often, but I would like to avoid
data corruption...

Regards,
Martin

--
Martin Hermanowski
http://martin.hermanowski.name

_______________________________________________
Xense-devel mailing list
[hidden email]
http://lists.xensource.com/xense-devel