unstable build broken again

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

unstable build broken again

Mike Wray
The build is broken in unstable as of change set 1.5121:

 >bk pull
 >rm -rf dist
 >debug=y make world

gcc -Wall -Werror -g3 -D _XOPEN_SOURCE=600 -I ../../tools/python/xen/lowlevel/xc -I
../../tools/libxc -I ../../tools/libxutil -o xcsdump xcsdump.c -L../../tools/libxc
-L../../tools/libxutil \
               ctrl_interface.c evtchn.c dump.c -lxc -lxutil
install -d -m0755 -p /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -d -m0755 -p /home/mjw/repos-bk/xeno-unstable.bk/dist/install/usr/include
install -m0755 xcs /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -m0755 xcsdump /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -m0755 xcs_proto.h /home/mjw/repos-bk/xeno-unstable.bk/dist/install/usr/include
make[3]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcs'
make[3]: Entering directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcutils'
gcc   -m elf_i386    -o xc_restore
gcc: no input files
make[3]: *** [xc_restore] Error 1
make[3]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcutils'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools'
make[1]: *** [tools] Error 2
make[1]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk'
make: *** [world] Error 2

Mike

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

Keir Fraser

On 24 May 2005, at 09:57, Mike Wray wrote:

> gcc   -m elf_i386    -o xc_restore
> gcc: no input files

We just checked in a few fixes to the xcutils/Makefile, but none are
intended to fix the above error. I don't see how make can be missing
xc_restore.o as a prerequisite for xc_restore: very odd.

  -- Keir


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

David F Barrera
I don't know if this is the same error on the x86 builds, on FC3 and
SLES 9:

gcc -Wall -Werror -g3 -D _XOPEN_SOURCE=600 -
I ../../tools/python/xen/lowlevel/xc -I ../../tools/libxc -
I ../../tools/libxutil -o xcsdump xcsdump.c -L../../tools/libxc -
L../../tools/libxutil \
              ctrl_interface.c evtchn.c dump.c -lxc -lxutil
install -d -m0755 -p /tmp/xen-unstable/dist/install//usr/sbin
install -d -m0755 -p /tmp/xen-unstable/dist/install/usr/include
install -m0755 xcs /tmp/xen-unstable/dist/install//usr/sbin
install -m0755 xcsdump /tmp/xen-unstable/dist/install//usr/sbin
install -m0755 xcs_proto.h /tmp/xen-unstable/dist/install/usr/include
make[3]: Leaving directory `/tmp/xen-unstable/tools/xcs'
make[3]: Entering directory `/tmp/xen-unstable/tools/xcutils'
gcc   -m32 -march=i686 -Wall -Werror -O3 -fno-strict-aliasing -
I ../../tools/libxc -Wp,-MD,.xc_restore.o.d -c -o xc_restore.o
xc_restore.c
make[3]: *** No rule to make target `-lxc', needed by `xc_restore'.
Stop.
make[3]: Leaving directory `/tmp/xen-unstable/tools/xcutils'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/tmp/xen-unstable/tools'
make[1]: *** [tools] Error 2
make[1]: Leaving directory `/tmp/xen-unstable'
make: *** [world] Error 2
make world failed


On Tue, 2005-05-24 at 10:55 +0100, Keir Fraser wrote:

> On 24 May 2005, at 09:57, Mike Wray wrote:
>
> > gcc   -m elf_i386    -o xc_restore
> > gcc: no input files
>
> We just checked in a few fixes to the xcutils/Makefile, but none are
> intended to fix the above error. I don't see how make can be missing
> xc_restore.o as a prerequisite for xc_restore: very odd.
>
>   -- Keir
>
>
> _______________________________________________
> Xen-devel mailing list
> [hidden email]
> http://lists.xensource.com/xen-devel
>
--
Regards,

David F Barrera
Linux Technology Center
Systems and Technology Group, IBM

"The wisest men follow their own direction. "
                                                        Euripides


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

Mike Wray
In reply to this post by Keir Fraser
Keir Fraser wrote:

>
> On 24 May 2005, at 09:57, Mike Wray wrote:
>
>> gcc   -m elf_i386    -o xc_restore
>> gcc: no input files
>
>
> We just checked in a few fixes to the xcutils/Makefile, but none are
> intended to fix the above error. I don't see how make can be missing
> xc_restore.o as a prerequisite for xc_restore: very odd.
>

I get a different error now:

gcc -Wall -Werror -g3 -D _XOPEN_SOURCE=600 -I ../../tools/python/xen/lowlevel/xc -I
../../tools/libxc -I ../../tools/libxutil -o xcsdump xcsdump.c -L../../tools/libxc
-L../../tools/libxutil \
               ctrl_interface.c evtchn.c dump.c -lxc -lxutil
install -d -m0755 -p /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -d -m0755 -p /home/mjw/repos-bk/xeno-unstable.bk/dist/install/usr/include
install -m0755 xcs /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -m0755 xcsdump /home/mjw/repos-bk/xeno-unstable.bk/dist/install//usr/sbin
install -m0755 xcs_proto.h /home/mjw/repos-bk/xeno-unstable.bk/dist/install/usr/include
make[3]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcs'
make[3]: Entering directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcutils'
gcc   -m elf_i386   -L../../tools/libxc -L../../tools/libxutil -lxc -lxutil -o xc_restore
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../crt1.o(.text+0x18): In function `_start':
../sysdeps/i386/elf/start.S:77: undefined reference to `main'
collect2: ld returned 1 exit status
make[3]: *** [xc_restore] Error 1
make[3]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools/xcutils'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk/tools'
make[1]: *** [tools] Error 2
make[1]: Leaving directory `/home/mjw/repos-bk/xeno-unstable.bk'
make: *** [world] Error 2

Looking at the gcc line it's only linking -L libs and crt1.0, no other objects.

Mike

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

Keir Fraser

On 24 May 2005, at 14:59, Mike Wray wrote:

>> We just checked in a few fixes to the xcutils/Makefile, but none are
>> intended to fix the above error. I don't see how make can be missing
>> xc_restore.o as a prerequisite for xc_restore: very odd.
>>
>
> I get a different error now:

Different error, same cause. :-)

As I said, it's very odd (maybe a bug in some versions of make), but
anyway: I think the fix I just checked in ought to get things working
for you again.

  -- Keir


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

Mike Wray
Keir Fraser wrote:

>
> On 24 May 2005, at 14:59, Mike Wray wrote:
>
>>> We just checked in a few fixes to the xcutils/Makefile, but none are
>>> intended to fix the above error. I don't see how make can be missing
>>> xc_restore.o as a prerequisite for xc_restore: very odd.
>>>
>>
>> I get a different error now:
>
>
> Different error, same cause. :-)
>
> As I said, it's very odd (maybe a bug in some versions of make), but
> anyway: I think the fix I just checked in ought to get things working
> for you again.

I think the problem is that the Makefile uses $(eval) - it's
not in the info for my version of make, and make being the way it
is it will evaluate to nothing (silently). So the expanded
program template doesn't set up the dependencies and the link
has no files to link.

Mike

_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel
Reply | Threaded
Open this post in threaded view
|

Re: unstable build broken again

Keir Fraser

On 24 May 2005, at 15:33, Mike Wray wrote:

>> Different error, same cause. :-)
>> As I said, it's very odd (maybe a bug in some versions of make), but
>> anyway: I think the fix I just checked in ought to get things working
>> for you again.
>
> I think the problem is that the Makefile uses $(eval) - it's
> not in the info for my version of make, and make being the way it
> is it will evaluate to nothing (silently). So the expanded
> program template doesn't set up the dependencies and the link
> has no files to link.

In that case, even the 'fixed' Makefile probably does not work for you?

  -- Keir


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel