xen-unstable kernel 2.4 compile problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

xen-unstable kernel 2.4 compile problem

netz-haut - stephan seitz
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello listmembers,

i'm currently trying to compile the linux 2.4.30 as xenU in xen-unstable.
I'm getting errors about undefined HYPERVISOR_block() and
HYPERVISOR_yield() functions
around process.c (cpu_idle loop).
Well, there'll possibly be a lot more errors further down the compile
process, but
i'm trying to migrate the 2.4.30 step-by-step.
After reviewing the xen-2.0-testing (with working and running
2.4.30-xenU) i noticed, that
xen-unstable handles HYPERVISOR functions way other than 2.x.
Is there any function documentation existing, or does anybody of you
know, how to replace
these functions by the newer ones (i assume, HYPERVISOR_vcpu_op() ??).
Maybe i'm completly wrong, but even then it would be helpful if
someone could give me some
hints.

Thanks in advance.

Stephan Seitz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDTO4c0MKSfkbzHDYRAokcAKC5veMueKoSic5lMTG39Kz7yE1ymACfUwzA
PClVtU+mgoU6JxZza9qx0IM=
=3RyJ
-----END PGP SIGNATURE-----


_______________________________________________
Xen-devel mailing list
[hidden email]
http://lists.xensource.com/xen-devel