Quantcast

xend won't start after upgrade

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

xend won't start after upgrade

andy smith-10
Hi,

I just attempted to upgrade from a xen 2.0.5 debian package to a
2.0-testing from source circa 25th May.  I downloaded the
2.0-testing tgz, unpacked, compiled and installed without incident.

After rebooting my dom0 does boot correctly, however xend does not
start.  Trying "/usr/sbin/xend start" from the command line, it
instantly returns to the prompt with no error message and nothing
useful in /var/log/xend.log.

After this I can see there is an xfrd process, but no xend process.
There is a /var/run/xend.pid file but the pid it references does not
exist.

I did a strace of the daemon and through my python-ignorant eyes it
seems like it is not finding a bunch of files.

You can find the strace output here:

http://strugglers.net/~andy/tmp/

xend.27513 is the one with the same pid as in /var/run/pid.

Please can anyone help me out as to why xend will not start?

Thanks,
Andy

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xend won't start after upgrade

andy smith-10
On Sat, May 28, 2005 at 10:08:15PM +0000, Andy Smith wrote:
> After rebooting my dom0 does boot correctly, however xend does not
> start.  Trying "/usr/sbin/xend start" from the command line, it
> instantly returns to the prompt with no error message and nothing
> useful in /var/log/xend.log.

After checking back in my archives of this list (sorry), I see this
is actually the problem where xend gets its database corrupted.  I
blew away /var/lib/xen/xend-db and everything seems to be OK now.

_______________________________________________
Xen-users mailing list
[hidden email]
http://lists.xensource.com/xen-users

signature.asc (196 bytes) Download Attachment
Loading...